Cash Machine

Cash Machine
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 20000/10000K(Java/Other)
Total Submission(s) : 0 Accepted Submission(s) : 0
Problem Description
A Bank plans to install a machine for cash withdrawal. The machineis able to deliver appropriate @ bills for a requested cash amount.The machine uses exactly N distinct bill denominations, say Dk,k=1,N, and for each denomination Dk the machine has a supply of nkbills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of @100 each, 4 bills of@50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliverand write a program that computes the maximum amount of cash lessthan or equal to cash that can be effectively delivered accordingto the available bill supply of the machine.

Notes:
@ is the symbol of the currency delivered by the machine. Forinstance, @ may stand for dollar, euro, pound etc.


Input
The program input is from standard input. Each data set in theinput stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 ... nN DN

where 0 <= cash <= 100000 is theamount of cash requested, 0 <=N <= 10is the number of bill denominations and 0 <= nk<= 1000 is the number of available bills for the Dkdenomination, 1 <= Dk <= 1000, k=1,N.White spaces can occur freely between the numbers in the input. Theinput data are correct.


Output
For each set of data the program prints the result to the standardoutput on a separate line as shown in the examples below.


Sample Input
735 3 4 125 6 5 3 350
633 4 500 30 6 100 1 5 0 1
735 0
0 3 10 100 10 50 10 10


Sample Output
735
630
0
0


Source
PKU

背包

c++ source code:

#include<iostream>

#include <cstdio>
using namespace std;
int f[100001];
int num[1001];
int value[1001];
int m, n;
void CompletePack( int val ) {
int i;
for( i = val; i <= m; i++ )
f[i] += f[i-val];
}
void ZeroOnePack( int val ) {
int i;
for( i = m; i >= val; i-- )
f[i] += f[i-val];
}
int main() {
int i, j;
while( scanf("%d%d", &m, &n) != EOF) {
for( i = 1; i <= n; i++ )
scanf("%d%d", &num[i],&value[i]);
f[0] = 1;
for( i = 1; i <= m; i++ )
f[i] = 0;
for( i = 1; i <= n; i++) {
if( num[i] * value[i] >= m ) {
CompletePack(value[i]);//完全背包
continue;
}
int sum = num[i], k = 1;
while( k < sum ) {
ZeroOnePack(k*value[i]);//01背包
sum -= k;
k = k*2;
}
ZeroOnePack(sum*value[i]);
}
int flag = 0;
for( i = m; i >= 0; i-- ) {
if( f[i] ) {
flag = 1;
printf("%d/n", i);
break;
}
}
if( !flag )
printf("0/n");
}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值