使用jdk1.8出现有些类can not be resolved的情况

版权声明:本文为博主原创文章,遵循 CC 4.0 by-sa 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/k9526310/article/details/52000224
在开发的时候把jdk换成了1.8的,结果发现之前编辑的很多java类都can not be resolved了,我需要把数组输出一下,结果发现Arrays.toString()的时候Arrays类can not be resolved,后来百度说是eclipse版本和jdk的不匹配,要重新下一个低一点的版本,后面研究发现确实重新安装一个低一点的版本的jdk就行了,不过不需要卸载jdk1.8的,也不需要重新配置环境变量,保留两个jdk就好,只不过在编译的时候换成低版本的编译(我安装的是1.7的)。具体操作:(1)安装多一个低版本的jdk,注意安装正确,安装目录另外选一个,jdk和jre分开。(2)给eclipse增加一个jre环境,方法:windown-->preferences-->java-->installed jres,然后add,next选择安装的低版本的jre的安装目录,finish,ok就可以为eclipse添加一个jre了。(3)然后选择项目右键build path把jre system library1.8 remove掉,再点击add library-->jre system library-->alternate 选择低版本的jdk,finish就返回ok可以了.总之就是把换成这样就ok了

cannot be resolved,cannot be resolvedcannot be resolvedpreinxuazzzzz

展开阅读全文

没有更多推荐了,返回首页