Curling 2.0 【深搜】

Curling 2.0

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.

Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

At the beginning, the stone stands still at the start square.
The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
Once thrown, the stone keeps moving to the same direction until one of the following occurs:
The stone hits a block (Fig. 2(b), (c)).
The stone stops at the square next to the block it hit.
The block disappears.
The stone gets out of the board.
The game ends in failure.
The stone reaches the goal square.
The stone stops there and the game ends in success.
You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.

Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).

Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board
First row of the board

h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0 vacant square
1 block
2 start position
3 goal position
The dataset for Fig. D-1 is as follows:

6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input

2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0

Sample Output

1
4
-1
4
10
-1

题意概括:

  0 代表空地 ,1 代表墙,2代表起始点, 3代表终点。冰壶可以向上下左右四个方向移动,但与之挨着的那一格是墙的话将不能向该方向移动。若冰壶向一个方向移动只有碰到墙或到达终点才能停止,如果是碰到墙则碰到的那个墙将消失,且冰壶停在墙前一格。

解题分析:

  这道题不难看出是一道搜索题,但因为地图一直处于变换中,所以应采用深度优先搜索(dfs)。若采用广度优先搜索(bfs)则需要不断地存储图,对于时间复杂度和空间复杂度都比较高,所以还是采用深搜方便。

易错分析:

  当冰壶在一个方向上行进时,若出界则被视为游戏失败,这种情况需要考虑。

AC代码:
#include<stdio.h>
#include<string.h>

#define N 25
#define inf 99999999

int e[N][N], Next[4][2] = {1, 0, 0, 1, -1, 0, 0, -1};
int n, m, flag;

void dfs(int x, int y, int t)
{
    int i, tx, ty, logo;
    if(t > 10) return ;
    for(i = 0; i < 4; i++){
        tx = x+Next[i][0];
        ty = y+Next[i][1];
        if(tx < 0 || ty < 0 || tx >= n || ty >= m || e[tx][ty] == 1) continue;
        logo = 0;
        while(e[tx][ty] != 1 && e[tx][ty] != 3){
            tx += Next[i][0];
            ty += Next[i][1];
            if(tx < 0 || ty < 0 || tx >= n || ty >= m){//判断在行进时是否出界
                logo = 1;
                break;
            }
        }
        if(logo) continue;//若出界视为游戏失败
        if(e[tx][ty] == 3){
            if(t < flag) flag = t;
            continue;//此处应该是continue而不是return,仔细想一下就明白了
        }
        e[tx][ty] = 0;
        dfs(tx-Next[i][0], ty-Next[i][1], t+1);
        e[tx][ty] = 1;
    }
}

int main()
{
    int i, j, x, y;
    while(scanf("%d%d", &m, &n), n || m){
        flag = inf;
        for(i = 0; i < n; i++){
            for(j = 0; j < m; j++){
                scanf("%d", &e[i][j]);
                if(e[i][j] == 2) x = i, y = j;
            }
        }
        dfs(x, y, 1);
        if(flag != inf) printf("%d\n", flag);
        else printf("-1\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值