java "lambda expressions not supported at this language level"

出自:https://blog.csdn.net/bitcarmanlee/article/details/70195149

1.修改project的JDK版本

File -> Project Structure -> Project,将Project Language Level设置为8.0 - Lambdas, type annotations etc.这一项。 
这里写图片描述

2.修改module的JDK版本

将Project选项里的jdk版本修改以后还不够,还需要将对应module版本也修改正确。File -> Project Structure -> Modules里,将Language Level也设置为8.0 - Lambdas, type annotations etc.这一项。 
这里写图片描述

将以上两项都修改完毕以后,就OK了。

©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页