Prime Ring Problem

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. 

Note: the number of first circle should always be 1. 

 
Input
n (0 < n < 20). 
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order. 

You are to write a program that completes above process. 

Print a blank line after each case. 
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
 
 
题意:按字典序输出素数环,素数环就是两两相邻的两个数相加 和为素数
#include<cstdio>
#include<cmath>
#include<cstring>
int vis[20];
int num[20];
int n;
int sushu(int x)//判断是否为素数
{
    int i,k=sqrt(x);
    for(i=2;i<=k;i++)
    {
        if(x%i==0)
            break;
    }
    if(i>k&&x!=1)//1不是素数
        return 1;
    return 0;
}
void dfs(int index)
{
    if(index==n)
    {
        if(sushu(num[index]+num[1]))//输出答案
        {
            for(int i=1;i<n;i++)
                printf("%d ",num[i]);
            printf("%d\n",num[n]);
        }
    }
    for(int i=2;i<=n;i++)
    {
        if(!vis[i]&&sushu(num[index]+i))
        {
            vis[i]=1;
            num[index+1]=i;//注意这里自加用index+1;
            dfs(index+1);
            vis[i]=0;//回溯回去的时候把标记清除掉
        }
    }
}
int main()
{
    int Case=1;
    while(~scanf("%d",&n))
    {
        memset(vis,0,sizeof(vis));
        printf("Case %d:\n",Case++);
        if(n%2&&n!=1)//n为奇数是不可能存在素数环的,所以可以直接跳过,加速;
        {
            printf("\n");
            continue;
        }
        num[1]=1;
        dfs(1);
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值