Substrings

You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings. 
Input
The first line of the input file contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains a single integer n (1 <= n <= 100), the number of given strings, followed by n lines, each representing one string of minimum length 1 and maximum length 100. There is no extra white space before and after a string. 
Output
There should be one line per test case containing the length of the largest string found. 
Sample Input
2
3
ABCD
BCDFF
BRCD
2
rose
orchid
Sample Output
2
2
题意:找出字符串的最长连续公共子串
#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
int main()
{
    int t,n;
    string str[101];
    cin>>t;
    while(t--)
    {
        int ok=0;
        int x,minn=101,maxx=0;
        cin>>n;
        for(int i=0;i<n;i++)
        {
             cin>>str[i];
             //reverse(str[i].begin(),str[i].end());
             if(str[i].length()<minn)
             {
                 minn=str[i].length();
                 x=i;
             }
        }
        //cout<<minn<<endl;
        for(int i=str[x].length();i>0;i--)
        {
            for(int j=0;j<str[x].length()-i+1;j++)
            {
                int l;
                string str1=str[x].substr(j,i);
                string str2=str1;
                reverse(str2.begin(),str2.end());
                for(l=0;l<n;l++)
                {
                    if(str[l].find(str1)==-1&&str[l].find(str2)==-1)
                        break;
                }
                if(l==n)
                {
                    maxx=str1.length();
                    ok=1;
                    break;
                }
            }
            if(ok)
                break;
        }
        cout<<maxx<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值