Til the Cows Come Home

Til the Cows Come Home
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 55966 Accepted: 18983

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define N 2010
#define MAX 99999999
using namespace std ;
struct node
{
    int a,b,w;
} f[N];
int n,m;
void bell()
{
    int i,j;
    int  d[N];
    for(int i =1 ; i<=n; i++)
        d[i]=MAX;
    d[1]=0;
    for(i=1; i<n; i++)
    {
        for(j=1; j<=m; j++)
        {
            if(d[f[j].b]>d[f[j].a]+f[j].w)
                d[f[j].b]= d[f[j].a]+f[j].w;
            /*一般是只要这一个判断就可以了的,但是这道题会有重边,比如代码后面的样例,
            所以还要加上下面这个判断条件,因为这个可能路径更短*/
            if(d[f[j].a]>d[f[j].b]+f[j].w)
                d[f[j].a]= d[f[j].b]+f[j].w;
        }
    }
    printf("%d\n",d[n]);
}
int main()
{
    int i,a,b,c;
    while(cin>>m>>n)
    {
        for(int i =1; i<=m; i++)
        {
            cin>>a>>b>>c;
            f[i].a=a;
            f[i].b=b;
            f[i].w=c;
        }
        bell();
    }
    return 0 ;
}
/*
注意是先输入边然后再输入点的
6 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100
2 1 10
答案应该是80
*/
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值