Triangle

Triangle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1365    Accepted Submission(s): 809


Problem Description
Mr. Frog has n sticks, whose lengths are 1,2, 3 n respectively. Wallice is a bad man, so he does not want Mr. Frog to form a triangle with three of the sticks here. He decides to steal some sticks! Output the minimal number of sticks he should steal so that Mr. Frog cannot form a triangle with
any three of the remaining sticks.
 

Input
The first line contains only one integer T ( T20 ), which indicates the number of test cases.

For each test case, there is only one line describing the given integer n ( 1n20 ).
 

Output
For each test case, output one line “Case #x: y”, where x is the case number (starting from 1), y is the minimal number of sticks Wallice should steal.
 

Sample Input
  
  
3 4 5 6
 

Sample Output
  
  
Case #1: 1 Case #2: 1 Case #3: 2
题意:3个测试样例,每个测试样例有一个数n:表示n根长度分别为1,2,3,........,n的木棍,求最少拿走几根木棍,可以使得剩下的木棍都不能组成三角
#include <cstdio>
#include <queue>
#include <algorithm>
using namespace std;
int main()
{
    int a[25];
    a[1]=a[2]=a[3]=0;
    int n,t;
    queue<int> Q;
    Q.push(3);
    Q.push(2);
    int k=4,ans=0;
    while(k<=20)
    {
        int x=Q.front();
        Q.pop();
        int y=Q.front();
        if(x+y>k)
        {
            ans++;
            a[k]=ans;
            Q.push(x);
        }
        else
        {
            a[k]=ans;
            Q.push(k);
        }
        k++;
    }
    int Cas=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        printf("Case #%d: %d\n",Cas++,a[n]);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值