hdu 1051-Wooden Sticks

Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).


Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.


Output
The output should contain the minimum setup time in minutes, one per line.


Sample Input

3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1



Sample Output

2
1

3

意思是给你几组木棍的长度和重量,从第二组开始,如果后边木棍数据的长度和重量大于前一组(不一定连续),则不加时间,否则加一分钟,求最少时间

比如(4 ,9),(5 ,2),(2,1),(3,,5),(1,4),先对其中一种数据排序(长度或重量都可以),比如对长度从小到大排序,

则数据变为(1,4),(2,1),(3,5),(4,9),(5,2),则满足条件的结果为【(1,4),(3,5),(4,9)】,【(2,1),(5,2)】,共需要2分钟。

#include <stdio.h>
#include<string.h>
int main ()
{
    int a[5005],b[5005],c[5005];
    int n,i,j;
    int t,temp;
    int num,sum;
    int max1,max2;
    scanf ("%d",&t);
    while (t--)
    {
        num=1;
        sum=0;
        memset (c,0,sizeof(c));
        scanf ("%d",&n);
        for (i=0;i<n;i++)
        {
            scanf ("%d",&a[i]);
            scanf("%d",&b[i]);
        }
              for (i=0;i<n;i++)
            for(j=i;j<n;j++)
        {
            if(a[i]<a[j])
            {
                temp=a[i];a[i]=a[j];a[j]=temp;
                temp=b[i];b[i]=b[j];b[j]=temp;
            }
        }
        while(num)
        {
            num=0;
            max1=max2=30005;
            for(i=0;i<n;i++)
            {
                if(c[i]==0)
                {
                    if(max1>=a[i] && max2>=b[i])
                    {
                        max1=a[i];
                        max2=b[i];
                        c[i]=1;
                    }
                    num=1;
                }
            }
            sum++;
        }
        printf("%d\n",sum-1);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值