HDU-1079 Calendar Game (简单博弈)

Calendar Game

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3935 Accepted Submission(s): 2374

Problem Description


Adam and Eve enter this year’s ACM International Collegiate Programming Contest. Last night, they played the Calendar Game, in celebration of this contest. This game consists of the dates from January 1, 1900 to November 4, 2001, the contest day. The game starts by randomly choosing a date from this interval. Then, the players, Adam and Eve, make moves in their turn with Adam moving first: Adam, Eve, Adam, Eve, etc. There is only one rule for moves and it is simple: from a current date, a player in his/her turn can move either to the next calendar date or the same day of the next month. When the next month does not have the same day, the player moves only to the next calendar date. For example, from December 19, 1924, you can move either to December 20, 1924, the next calendar date, or January 19, 1925, the same day of the next month. From January 31 2001, however, you can move only to February 1, 2001, because February 31, 2001 is invalid.

A player wins the game when he/she exactly reaches the date of November 4, 2001. If a player moves to a date after November 4, 2001, he/she looses the game.

Write a program that decides whether, given an initial date, Adam, the first mover, has a winning strategy.

For this game, you need to identify leap years, where February has 29 days. In the Gregorian calendar, leap years occur in years exactly divisible by four. So, 1993, 1994, and 1995 are not leap years, while 1992 and 1996 are leap years. Additionally, the years ending with 00 are leap years only if they are divisible by 400. So, 1700, 1800, 1900, 2100, and 2200 are not leap years, while 1600, 2000, and 2400 are leap years.


Input


The input consists of T test cases. The number of test cases (T) is given in the first line of the input. Each test case is written in a line and corresponds to an initial date. The three integers in a line, YYYY MM DD, represent the date of the DD-th day of MM-th month in the year of YYYY. Remember that initial dates are randomly chosen from the interval between January 1, 1900 and November 4, 2001.


Output

Print exactly one line for each test case. The line should contain the answer "YES" or "NO" to the question of whether Adam has a winning strategy against Eve. Since we have T test cases, your program should output totally T lines of "YES" or "NO".


Sample Input


3
2001 11 3
2001 11 2
2001 10 3


Sample Output
YES
NO
NO

题意:从1900.1.1到2001.11.04中输入一个日期,两个人轮流移动日期,每次移动可以到当前日期的下一天或者下一个月的当前天,如果不存在,只能移动到下一天,比如,1924.12.19可以移动到1924.12.20或者1925.1.19,

但是2001.1.31只能移动到2001.2.1,因为2001.2.31是不存在的。。最后谁先移到2001.11.04谁赢。。

思路:假设2001年11月3号是先手的必胜态,则11.02是必输态,因为没有2002.11.02,所以只能移动到下一天,于是使对方达到了必胜态(11.03),那么2001.11.02是先手的必败态,依次往后推,每一次,都要看如果往后走一天或者到下个月相同一天,如果这两种选择都使得对方到达必胜态,那么当前点就是必输态,否则如果其中一种选择使得对方到达必输态,那么当前点就是必胜态,,,

       最后发现,当月份和天数互为奇偶时,一定是必输态,,除了9月30号与11月30号,,


以下AC代码:

#include<stdio.h>
int main()
{
    int t;
    int y,m,d;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&y,&m,&d);
        if((d+m)%2==0)
            printf("YES\n");
        else if(m==9 && d==30)
            printf("YES\n");
        else if(m==11 && d==30)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值