POJ 1730 Perfect Pth Powers 解题报告(因式分解)

96 篇文章 0 订阅
Perfect Pth Powers
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 16348 Accepted: 3704

Description

We say that x is a perfect square if, for some integer b, x = b 2. Similarly, x is a perfect cube if, for some integer b, x = b 3. More generally, x is a perfect pth power if, for some integer b, x = b p. Given an integer x you are to determine the largest p such that x is a perfect p th power.

Input

Each test case is given by a line of input containing x. The value of x will have magnitude at least 2 and be within the range of a (32-bit) int in C, C++, and Java. A line containing 0 follows the last test case.

Output

For each test case, output a line giving the largest integer p such that x is a perfect p th power.

Sample Input

17
1073741824
25
0

Sample Output

1
30
2

    解题报告:记得以前做过的题,还是被坑了。
    没搞清楚题意,不知道x可以是负数,得出的结论就是一定要看清楚题目的意思。
    知道x可能是负数后,可以推导出当x是负数时,p一定是奇数。
    最大的p就是所有质因子的幂的最大公约数,x是负数时则一直除2。代码如下:
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
using namespace std;

typedef long long LL;

int gcd(int a, int b)
{
    return b==0?a:gcd(b, a%b);
}

void work(LL n)
{
    bool flag=(n<0);
    if(n<0) n=-n;

    int a=-1;
    int m = sqrt((double)n)+1;

    for(int i=2;i<=m;i++) if(n%i==0)
    {
        int t=0;
        while(n%i==0) n/=i, t++;

        if(a==-1)
            a=t;
        else
            a=gcd(a, t);
    }

    if(n>1) a=1;

    while(flag && a%2==0) a>>=1;
    printf("%d\n", a);
}

int main()
{
    LL n;
    while(~scanf("%lld", &n) && n)
        work(n);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值