Uva 1315 - Crazy tea party 解题报告(找规律)

96 篇文章 0 订阅

1315 - Crazy tea party

Time limit: 3.000 seconds

n participants of �crazy tea party� sit around the table. Each minute one pair of neighbors can change their places. Find the minimum time (in minutes) required for all participants to sit in reverse order (so that left neighbors would become right, and right - left).

Input 

The first line is the amount of tests. Each next line contains one integer n (1 <= n <= 32767) - the amount of crazy tea participants.

Output 

For each number n of participants to crazy tea party print on the standard output, on a separate line, the minimum time required for all participants to sit in reverse order.

Sample Input 

3
4
5
6

Sample Output 

2
4
6

    解题报告:将n个参与者的顺序反向,每次只能交换相邻的两个人。

    分析一下,1个人和2个人的时候不用操作,3个人的时候将2,3调换顺序即可。4个人的时候将1,2互换,3,4互换。

    这么来看,每次我们将n个人分成n/2和n-n/2两组,每组都要反向。递推一下可知,反响一段m长度的序列需要m*(m-1)/2次操作。故代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int cal(int n)
{
    return n*(n-1)/2;
}

void work()
{
    int n;
    scanf("%d",&n);

    printf("%d\n", cal(n/2)+cal(n-n/2));
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
        work();
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值