UVa 1344 Tian Ji -- The Horse Racing 解题报告(贪心)

56 篇文章 0 订阅

1344 - Tian Ji -- The Horse Racing

Time limit: 3.000 seconds

Here is a famous story in Chinese history.

That was about 2300 years ago. General Tian Ji was a high official in the country Qi.He likes to play horse racing with the king and others.
Both of Tian and the king have three horses in different classes, namely, regular, plus,and super. The rule is to have three rounds in a match; each of the horses must be used inone round. The winner of a single round takes two hundred silver dollars from the loser.
Being the most powerful man in the country, the king has so nice horses that in each classhis horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian.
Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generalsin Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundredsilver dollars and such a grace in the next match.
It was a rather simple trick. Using his regular class horse race against the super class fromthe king, they will certainly lose that round. But then his plus beat the king's regular, andhis super beat the king's plus. What a simple trick. And how do you think of Tian Ji, thehigh ranked official in China?
\epsfbox{p3266.eps}

Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting inthe ACM contest right now, he may discover that the horse racing problem can be simply viewedas finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and theking's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw anedge between them, meaning we wish to establish this pair. Then, the problem of winning as manyrounds as possible is just to find the maximum matching in this graph. If there are ties, theproblem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possibleedges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses -- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.

Input 

The input consists of up to 50 test cases. Each case starts with a positive integer n (n$ \le$1000) onthe first line, which is the number of horses on each side. The next n integers on the second lineare the speeds of Tian's horses. Then the next n integers on the third line are the speeds of theking's horses. The input ends with a line that has a single `0' after the last test case.

Output 

For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

Sample Input 

3 
92 83 71  
95 87 74 
2 
20 20 
20 20 
2 
20 19 
22 18 
0

Sample Output 

200 
0 
0

    解题报告: 经典贪心。

    贪心策略为: 当前局面,能赢就赢。不能赢的情况下就用自己最差的马消耗掉对方最快的马。

    代码如下:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <string>
using namespace std;

#define ff(i, n) for(int i=0;i<(n);i++)
#define fff(i, n, m) for(int i=(n);i<=(m);i++)
#define dff(i, n, m) for(int i=(n);i>=(m);i--)
#define mem(a) memset((a), 0, sizeof(a))
typedef long long LL;
typedef unsigned long long ULL;
void work();

int main()
{
#ifdef ACM
    freopen("in.txt", "r", stdin);
//    freopen("in.txt", "w", stdout);
#endif // ACM

    work();
}

/*****************************************/

int a[1111], b[1111];

void work()
{
    int n;
    while(~scanf("%d", &n) && n)
    {
        ff(i, n) scanf("%d", a+i);
        ff(i, n) scanf("%d", b+i);

        sort(a, a+n);
        sort(b, b+n);

        int ans = 0;

        int ab=0, at=n-1;   // a bottom, a top
        int bb=0, bt=n-1;   // b bottom, b top

        while(ab<=at && bb<=bt)
        {
            if(a[at] > b[bt])   // 田忌最快的马比齐王最快的马快,胜一场
            {
                ans++, at--, bt--;
                continue;
            }

            if(a[ab] > b[bb])   // 田忌最慢的马比齐王最慢的马快,胜一场
            {
                ans++, ab++, bb++;
                continue;
            }

            if(a[ab] < b[bt])   // 田忌最慢的马比齐王最快的马慢,输一场(可能是平局)
                ans--;
            ab++, bt--;
        }

        printf("%d\n", ans*200);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值