安卓多Module 引用aar 的问题

遇到问题 在多Module时,一个Module引用aar 结果编译出错 Failed to resolve: :AliyunSdk-RC: 

按照规范把aar文件放到 libs 目录下面,在 MODULE 目录下面 build.gralde 中添加如下配置:

repositories {
    flatDir {
        dirs 'libs'
    }
}

在 dependencies block中添加如下代码:

 

dependencies {
    implementation fileTree(include: ['*.jar'], dir: 'libs')
    api externalAndroidAppCompatV7
    api externalAndroidRecyclerView
//    api project(':AliyunVideoSdk')
//    api project(':AlivcCore')
    api(name:'AliyunSdk-RC',ext:'aar')
}

结果其它的Module有依赖这个Module的就会出现上面错误。

以阿里视频为例:Module  base 依赖 core 和 sdk_rc ,crop 和record 依赖base, 此时把sdk_rc 换成aar 就会在crop 和 record 中出错,

方案一:把sdk_rc 导入项目,以Module方式,然后依赖project方式。实现方式:

dependencies {
    api project(':AliyunSVideoBase')
}

如此便可以层层传递了。(阿里本身demo也是这样的)

方案二:如果就是想要用aar的怎么办,可以在

Project 下的 build.gradle 中的 repositories 中添加相应的引用呢?默认的配置如下:

allprojects {
    repositories {
        jcenter()
    }
}

那就试一试吧,在 repositories 下添加 flatDir 试试。代码如下:

注意:这里一定是在 Project 下面的 build.gradle 中添加。把aar文件拷贝到App的 libs 目录下配置

  • flatDir{
        dirs  project(':app').file('libs')
    }

注意:是在allprojects 下的repositories,不是在buildscript下的repositories,buildscript下的repositories是用来说明gradle插件的位置。 同时,需要配置aar的地方用

api(name:'AliyunSdk-RC',ext:'aar')

ok,完成。

https://stackoverflow.com/questions/24506648/adding-local-aar-files-to-gradle-build-using-flatdirs-is-not-working

  • 0
    点赞
  • 0
    评论
  • 1
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

©️2021 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值