The Frog's Games
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65768/65768 K (Java/Others)Total Submission(s): 2187 Accepted Submission(s): 1153
Problem Description
The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).
Input
The input contains several cases. The first line of each case contains three positive integer L, n, and m.
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.
Output
For each case, output a integer standing for the frog's ability at least they should have.
Sample Input
6 1 2 2 25 3 3 11 2 18
Sample Output
4 11
Source
Recommend
lcy
题解:当青蛙跳长等于河宽L时它一定能跳过河。那么通过二分跳长,求出能过河的最短跳长。
好久没写过二分了。一开始没有想到是二分,我一直以石子为中心思考,而题解二分的对象是步长。
验证总是比求解容易。
PS:如果用C++的输入输出,一定要加 std::ios::sync_with_stdio(false); 否则会TLE(如同)
#include <iostream>
#include <algorithm>
using namespace std;
int prime(int);
int l,n,m,i,a[500010],leftn,rightn,midn;
int main(){
std::ios::sync_with_stdio(false);
while (cin>>l>>n>>m){
for (i=1;i<=n;++i) cin>>a[i];
a[0]=0; a[n+1]=l;
sort (a+1,a+n+1);
leftn=1; rightn=l; n++;
while (leftn<=rightn){
midn=(leftn+rightn)/2;
if (prime(midn)) rightn=midn-1;
else leftn=midn+1;
}
cout<<leftn<<endl;
}
return 0;
}
int prime(int b){
if (b*m<l) return 0;
int i,j,k;
i=0; k=0;
while (i<n){
if (a[i+1]-a[i]>b) return 0;
else{
i++; k++;
if (k>m) return 0;
j=i;
while ((a[j+1]-a[i-1]<=b)&&(j<n))
j++;
i+=j-i;
}
}
return 1;
}
kdwycz的网站: http://kdwycz.com/
kdwyz的刷题空间:http://blog.csdn.net/kdwycz