HDU 2147 kiki's game 解题报告

kiki's game


Problem Description
Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the  checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly,  who will win the game?
 

Input
Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.

 

Output
If kiki wins the game printf "Wonderful!", else "What a pity!".
 

Sample Input
  
  
5 3 5 4 6 6 0 0
 

Sample Output
  
  
What a pity! Wonderful! Wonderful!
 

解法:
步骤1:将所有终结位置标记为必败点(P点);
步骤2: 将所有一步操作能进入必败点(P点)的位置标记为必胜点(N点)
步骤3:如果从某个点开始的所有一步操作都只能进入必胜点(N点) ,则将该点标记为必败点(P点) ;
步骤4: 如果在步骤3未能找到新的必败(P点),则算法终止;否则,返回到步骤2。



最开始看到解法首先想到的是用数组,无奈2000*2000的数组太大了,开全局都承受不了,于是在找规律。发现:

凡是n为奇数的那一行全部为N;凡是n为偶数的那一行都以2开头2 1循环出现(如图):



具体的话就自己观察吧

题目分析(设置标记点)代码:(2=P,N=1;)


#include<stdio.h>
int s[2000][2000];
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        int i,j;
    s[n][1]=2;
    for(i=n-1;i>0;i--)
    {
        if(s[i+1][1]==2)
            s[i][1]=1;
        else s[i][1]=2;
    }
    for(j=2;j<=m;j++)
    {
        if(s[n][j-1]==2)
            s[n][j]=1;
        else s[n][j]=2;
    }
    for(i=n-1;i>0;i--)
        for(j=2;j<=m;j++)
    {
        if(s[i][j-1]==2||s[i+1][j]==2||s[i+1][j-1]==2)
            s[i][j]=1;
        else s[i][j]=2;
    }
    for(i=1;i<=n;i++)
        {
            for(j=1;j<=m;j++)
        printf("%3d",s[i][j]);
        printf("\n");
        }
}

return 0;
}


题目AC代码:

#include<stdio.h>
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)&&m&&n)
    {
        if(n%2)
          {
                if(m%2)
                printf("What a pity!\n");
                else
                printf("Wonderful!\n");
            }
        else

            printf("Wonderful!\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
根据提供的引用内容,HDU1622是一道关于二叉树的题目,要求读入一系列二叉树的节点信息,输出它们的层序遍历结果。如果输入的二叉树不完整或存在重复节点,则输出"not complete"。下面是Java的实现代码: ```java import java.util.LinkedList; import java.util.Queue; import java.util.Scanner; public class Main { static class Node { int val; Node left, right; public Node(int val) { this.val = val; } } public static void main(String[] args) { Scanner sc = new Scanner(System.in); while (sc.hasNext()) { String s = sc.nextLine(); if (s.isEmpty()) { continue; } String[] nodes = s.split("\\s+"); Node root = new Node(Integer.parseInt(nodes[0].substring(1))); Queue<Node> queue = new LinkedList<>(); queue.offer(root); boolean isComplete = true; for (int i = 1; i < nodes.length - 1; i += 2) { Node cur = queue.poll(); if (!nodes[i].equals("()")) { cur.left = new Node(Integer.parseInt(nodes[i].substring(1))); queue.offer(cur.left); } else { isComplete = false; } if (!nodes[i + 1].equals("()")) { cur.right = new Node(Integer.parseInt(nodes[i + 1].substring(0, nodes[i + 1].length() - 1))); queue.offer(cur.right); } else { isComplete = false; } } if (!isComplete) { System.out.println("not complete"); continue; } StringBuilder sb = new StringBuilder(); queue.offer(root); while (!queue.isEmpty()) { Node cur = queue.poll(); sb.append(cur.val).append(" "); if (cur.left != null) { queue.offer(cur.left); } if (cur.right != null) { queue.offer(cur.right); } } System.out.println(sb.toString().trim()); } } } ```

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值