1075 PAT Judge (25 分)

1075 PAT Judge (25 分)

这道题有点难住我了,调bug了一小时,终于AC了

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤10​4​​), the total number of users, K (≤5), the total number of problems, and M (≤10​5​​), the total number of submissions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<vector>
#include<set>
using namespace std;
int n,k,m;
struct node{
	int id;
	bool submit[5]={0,0,0,0,0};//判断有没有提交过这道题
	int score[5]={-1,-1,-1,-1,-1};
	int total=-1;//主要是为了输出过了编译但总分为0的童鞋,设为0没法排序
	int perf=0;
}user[100001];
bool cmp(node a, node b){
	if(a.total!=b.total) return a.total>b.total;
	else{
		if(a.perf!=b.perf) return a.perf>b.perf;
		else{
			return a.id<b.id;
		}
	}
}
int main(){
	scanf("%d%d%d",&n,&k,&m);
	int p[k];
	for(int i=0;i<k;i++){
		scanf("%d",&p[i]);
	}
	int id,prob,sco;
	set<int> userid;
	for(int i=0;i<m;i++){
		scanf("%d%d%d",&id,&prob,&sco);
		if(sco!=-1){
			user[id].submit[prob-1]=true;
			user[id].id=id;
			user[id].total=0;
			user[id].score[prob-1]=max(sco,user[id].score[prob-1]);
			userid.insert(id);
		}
		else{
			user[id].submit[prob-1]=true;
		}
	}
	for(set<int>::iterator it=userid.begin();it!=userid.end();it++){
		id=*it;
		for(int i=0;i<k;i++){
			if(user[id].score[i]==p[i]) user[id].perf++;
			if(user[id].score[i]!=-1) user[id].total+=user[id].score[i];
		}
	}
	sort(user+1,user+n+1,cmp);
	int rank=1;
	for(int i=1;i<=userid.size();i++){
		if(i>1){
			if(user[i].total!=user[i-1].total) rank=i;
		}
		printf("%d %05d %d",rank,user[i].id,user[i].total);
		for(int j=0;j<k;j++){
			if(user[i].score[j]!=-1) printf(" %d",user[i].score[j]);
			else{
				if(user[i].submit[j]==false) printf(" -");
				else printf(" 0");
			}
		}
		printf("\n");
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值