Linux Mint软件安装问题--无法修正错误,因为您要求某些软件包保持现状

之前在Windows下一直使用的是网易云音乐听歌,现在安装了Linux Mint之后一直没安装音乐播放器,今天去网易云音乐官网中发现其有提供Linux版本的网易云音乐,赶紧下来感受一下,官网上提供了以下几个版本

这里下载的是ubuntu16.04(64位)版本,安装时发现终端上提示了各种错误,缺少很多依赖关系,经过一番苦战之后发现还是有一个顽固的依赖关系,如下


一直提示未安装gstream1.0-plugins-bad,根据提示使用apt-get install安装所缺少的软件包,又出现了新的提示,如下


有6个软件包依赖,而且还不会被安装,再次使用apt-get install安装这6个软件包,这次安装没出现问题,但再次安装gstreamer1.0-plugins-bad软件包时依然出现了该错误


可以看到libgstreamer-plugins-bad1.0-0软件包已经是最新的了,另外5个依赖软件包也已经是最新的,但还是提示:

E:无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

但是中午我在另外一个虚拟机中安装该版本的网易云音乐时却没出现该问题,虽然也会有软件依赖关系未安装,但安装完后就可以成功安装网易云音乐,在询问谷歌后发现有一样的问题,有说是软件源的问题,这个可能性很大,虽然不晓得为啥?我虚拟机中的软件源是Linux Mint默认的,而出问题的这个软件源被我改成国内的了,于是乎把软件源恢复成默认的软件源再次安装gstreamer1.0-plugins-bad,发现居然真的可以!既然成功安装了gstreamer1.0-plugins-bad,再次安装云音乐,哈哈,终于是没错了。


看来,软件源还是不能随随便便改成国内的呀,一不小心就出问题,你还不知道问题出在哪儿,之前是为了快速下载而改成国内的软件源真是得不偿失.终于可以快乐地听歌敲代码了。

最后稍微吐槽一下网易云音乐软件安装的问题,一次性安装还不行,不能自动安装软件依赖关系,应该学学wps,它在安装时就是一步到位。该休息了。。。

©️2020 CSDN 皮肤主题: 大白 设计师: CSDN官方博客 返回首页
实付0元
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值