Avoid The Lakes (深搜dfs)

Avoid The Lakes

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 194   Accepted Submission(s) : 108
Problem Description

Farmer John's farm was flooded in the most recent storm, a fact only aggravated by the information that his cows are deathly afraid of water. His insurance agency will only repay him, however, an amount depending on the size of the largest "lake" on his farm.

The farm is represented as a rectangular grid with N (1 ≤ N ≤ 100) rows andM (1 ≤ M ≤ 100) columns. Each cell in the grid is either dry or submerged, and exactlyK (1 ≤ KN × M) of the cells are submerged. As one would expect, a lake has a central cell to which other cells connect by sharing a long edge (not a corner). Any cell that shares a long edge with the central cell or shares a long edge with any connected cell becomes a connected cell and is part of the lake.

 

Input

* Line 1: Three space-separated integers: N, M, and K
* Lines 2..K+1: Line i+1 describes one submerged location with two space separated integers that are its row and column:R and C

 

Output

* Line 1: The number of cells that the largest lake contains. 

 

Sample Input
  
  
3 4 5 3 2 2 2 3 1 2 3 1 1
 

Sample Output
  
  
4
 

 

题目大意:

第一行N,M,K代表N*M的网格,其中5块为'lake',一下5行是'lake'的坐标,边相邻为一个湖,求最大的湖

 

思路:

要检查所有情况,所以深搜

 

#include<cstdio>
#include<cstring>
int max(int a,int b)
{
	return a>b?a:b;
}
struct str
{
	int x;
	int y;
}p[10000];
int vis[110][110],M,N,K,count,cnt,k;
void clc()//还原标记的函数
{
	for(int i=1;i<=N;i++)
		for(int j=1;j<=M;j++)
		{
			if(vis[i][j]==-1)
				vis[i][j]==0;	
		}
}
void find(int x,int y)//查找,并随后向四个方向递归
{
	if(x<=0||x>N||y<=0||y>M)
		return;
	if(vis[x][y]!=1)
		return;
	count++;
	vis[x][y]=-1;//查过的记-1,方便回查
	find(x-1,y);
	find(x+1,y);
	find(x,y-1);
	find(x,y+1);
}
int main()
{
	while(scanf("%d%d%d",&N,&M,&K)!=EOF)
	{
		memset(vis,0,sizeof(vis));//清空为0
		for(k=1;k<=K;k++)
		{
			scanf("%d%d",&p[k].x,&p[k].y);
			vis[p[k].x][p[k].y]=1;//湖记为1;
		}
		cnt=0;//计数
		for(int i=1;i<=N;i++)
			for(int j=1;j<=M;j++)
			{
				count=0;
				clc();
				find(i,j);
				cnt=max(cnt,count);//比较本次和之前的'湖'谁大			}	
		printf("%d\n",cnt);
	}	
	return 0;
}


 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值