Bone Collector 01背包模板

49 篇文章 0 订阅
22 篇文章 0 订阅

Bone Collector
Time Limit: 1000MS Memory Limit: 65536KB
Submit Statistic
Problem Description

Many years ago , in Teddy’s hometown there was a man who was called
“Bone Collector”. This man like to collect varies of bones , such as
dog’s , cow’s , also he went to the grave … The bone collector had a
big bag with a volume of V ,and along his trip of collecting there are
a lot of bones , obviously , different bone has different value and
different volume, now given the each bone’s value along his trip , can
you calculate out the maximum of the total value the bone collector
can get ?

Input

The first line contain a integer T , the number of cases. Followed by
T cases , each case three lines , the first line contain two integer N
, V, (N <= 1000 , V <= 1000 )representing the number of bones and the
volume of his bag. And the second line contain N integers representing
the value of each bone. The third line contain N integers representing
the volume of each bone.

Output

One integer per line representing the maximum of the total value
(this number will be less than 2^31).

Example Input

1
5 10
1 2 3 4 5
5 4 3 2 1
Example Output

14

blablabla: 看见这道是个英文题的时候感觉还挺好玩。。。不过没啥生词。。。
这就是个01背包模板

#include <stdio.h>
#include <bits/stdc++.h>
int w[1003],v[1003];
int max(int a,int b)
{
    return a>b?a:b;
}
int main( )
{
    int t;
    int n_s,v_s;
    int i,j,k;
    int ans[1000];
    int dp[1003];
    while(scanf("%d",&t)!=EOF)
    {
        while(t--)
        {
            memset(dp,0,sizeof(dp));
            scanf("%d%d",&n_s,&v_s);
            for(i=0;i<n_s;i++)
            {
              scanf("%d",&w[i]);
            }
            for(i=0;i<n_s;i++)
            {
                scanf("%d",&v[i]);
            }
            for(i=0;i<n_s;i++)
            {
                for(j=v_s;j>=v[i];j--)
                {
                    dp[j]=max(dp[j],dp[j-v[i]]+w[i]);
                }
            }
            printf("%d\n",dp[v_s]);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值