Talented Chef ZOJ - 3778

49 篇文章 0 订阅
13 篇文章 0 订阅

As we all know, Coach Gao is a talented chef, because he is able to
cook M dishes in the same time. Tonight he is going to have a hearty
dinner with his girlfriend at his home. Of course, Coach Gao is going
to cook all dishes himself, in order to show off his genius cooking
skill to his girlfriend.

To make full use of his genius in cooking, Coach Gao decides to
prepare N dishes for the dinner. The i-th dish contains Ai steps. The
steps of a dish should be finished sequentially. In each minute of the
cooking, Coach Gao can choose at most M different dishes and finish
one step for each dish chosen.

Coach Gao wants to know the least time he needs to prepare the dinner.

Input

There are multiple test cases. The first line of input contains an
integer T indicating the number of test cases. For each test case:

The first line contains two integers N and M (1 <= N, M <= 40000). The
second line contains N integers Ai (1 <= Ai <= 40000).

Output

For each test case, output the least time (in minute) to finish all
dishes.

Sample Input

2
3 2
2 2 2
10 6
1 2 3 4 5 6 7 8 9 10

Sample Output

3
10

示例一

3道菜 同时做两道
都需要2步,在表格中都要出现两次
做个表格

时间↓同时做的菜→            选择的M1    选择的M2             
第一分钟                     1          2
第二分钟                     1          3
第三分钟                     2          3

同理
第二个示例
只需要相应的菜的序号出现对应次数就可以

也就是需要总数一样多个格子来
,除以同时做的菜数就是竖着的时间

只需要注意
如果n<=m
那么时间则一定是最长的那个的

否则就算竖着的高度
注意最小也得是最长的那个

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int t;
    int i,j;
    while(scanf("%d",&t)!=EOF)
    {
        while(t--)
        {
            int n,m;
            scanf("%d%d",&n,&m);
            int sum=0;
            int mi=0;
            for(i=0; i<n; i++)
            {
                int x;
                scanf("%d",&x);
                sum+=x;
                if(x>mi) mi=x;
            }
            double  ans=sum*1.0/m;
            int y=ans;
            if(n<=m)
            {
                printf("%d\n",mi);
            }
            else
            {
                if(ans-int(ans)>0) y=int(ans)+1;
                if(y<mi)  y=mi;//至关重要
                printf("%d\n",y);
            }
        }

    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值