利用lazy显示树~(注意lazy的更新)

A - lazy标记
Time Limit:5000MS     Memory Limit:131072KB     64bit IO Format:%I64d & %I64u

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C abc" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q ab" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

注意就是 lazy的选取和更新问题

#include<cstdio>
#include<algorithm>
using namespace std;
struct node{
    int l,r;
    long long sum,lazy;
};
node tree[1000002];
long long data[1000002];
void build(int p,int l,int r)
{
    tree[p].l=l;
    tree[p].r=r;
    tree[p].lazy=0;
    if(l==r){
        tree[p].sum=data[l];
        return ;

    }
    int mid=(l+r)/2;
    build(p*2,l,mid);
    build(p*2+1,mid+1,r);
    tree[p].sum=tree[p*2].sum+tree[p*2+1].sum;

}
long long query(int p,int l,int r,int a,int b)
{
    if(a<=l&&b>=r)return tree[p].sum;
    int mid=(l+r)/2;
    if(tree[p].lazy!=0){
        tree[2*p].sum+=(mid-tree[p].l+1)*tree[p].lazy;
		tree[2*p].lazy+=tree[p].lazy;
		tree[2*p+1].sum+=(tree[p].r-mid)*tree[p].lazy;
		tree[2*p+1].lazy+=tree[p].lazy;
		tree[p].lazy=0;//pass down;
    }
    if(a>mid)return query(2*p+1,mid+1,r,a,b);
    if(b<=mid) return query(2*p,l,mid,a,b);
    return query(2*p+1,mid+1,r,mid+1,b)+query(2*p,l,mid,a,mid);

}
void alter(int p,int l,int r,int a,int b,long long  num)
{
    //printf("l = %d r = %d a = %d b = %d\n",l,r,a,b);
    if(a==l&&b==r){
       // printf("l = %d r = %d a = %d b = %d\n",l,r,a,b);
        tree[p].sum+=(r-l+1)*num;
        tree[p].lazy+=num;
        return;
    }
    int mid=(l+r)/2;
    if(tree[p].lazy!=0){
        tree[2*p].sum+=(mid-tree[p].l+1)*tree[p].lazy;
		tree[2*p].lazy+=tree[p].lazy;
		tree[2*p+1].sum+=(tree[p].r-mid)*tree[p].lazy;
		tree[2*p+1].lazy+=tree[p].lazy;
		tree[p].lazy=0;//pass down;
    }
    if(a>mid){
        alter(p*2+1,mid+1,r,a,b,num);
    }
    else if(b<=mid){
        alter(p*2,l,mid,a,b,num);
    }
    else {
        alter(p*2+1,mid+1,r,mid+1,b,num);
        alter(p*2,l,mid,a,mid,num);
    }
    tree[p].sum=(tree[p*2+1].sum+tree[p*2].sum);
}
int main()
{
    int  amm,req,i,a,b,u;
    char command;
    long long num;
    while(scanf("%d%d",&amm,&req)!=EOF){
    for(i=1;i<=amm;i++){
        scanf("%I64d",&data[i]);
    }
    build(1,1,amm);
    for(u=0;u<req;u++){
        scanf(" %c",&command);
        if(command=='Q'){
            scanf("%d%d",&a,&b);
            printf("%I64d\n",query(1,1,amm,a,b));
        }
        if(command=='C'){
            scanf("%d%d%I64d",&a,&b,&num);
            alter(1,1,amm,a,b,num);
        }
    }
    }
    return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值