倒序的拓扑排序

C - Labeling Balls
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

  1. No two balls share the same label.
  2. The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next Mline each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input

5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4

´ 应让结点 1 尽量排在前面,再使 2 尽量排在前面 ... ... 5 6 1 4 3 2  
´ 若直接按结点从小到大拓扑排序,无法得到正解: 4 3 2 5 6 1  
´ 反向拓扑排序,按结点从大到小的顺序这样能使结点小的尽可能的排在后面: 2 3 4 1 6 5 ,那么反过来的 5 6 1 4 3 2 就是所求的拓扑序列。 

注意要反向 拓扑!


#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int chudu[209];
int deg[209][209];
int wei[209];
int main()
{
	int cases;
	scanf("%d",&cases);
	while(cases--)
	{
		int n,m;
		scanf("%d%d",&n,&m);
		int i,j;
		int a,b;
		memset(deg,0,sizeof(deg));
		memset(chudu,0,sizeof(chudu));
		for(i=1;i<=m;i++)
		{
			scanf("%d%d",&a,&b);
			if(deg[a][b]==0)
			{
				deg[a][b]=1;
				chudu[a]++;
			}
		}
		memset(wei,0,sizeof(wei));
		int t=n;
		while(true)
		{
			for(i=n;i>=1;i--)
				if(wei[i]==0&&chudu[i]==0)
					break;
			if(i==0)
				break;
			wei[i]=t--;
			for(j=1;j<=n;j++)
				if(deg[j][i]==1)
					chudu[j]--;
		}
		if(t==0)
		{
			for(i=1;i<=n;i++)
			{
				if(i>1)
					printf(" ");
				printf("%d",wei[i]);
			}
			printf("\n");
		}
		else
			printf("-1\n");
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值