Drying POJ - 3104

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input
sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5
Sample Output
sample output #1
3

sample output #2
2


枚举一个mid值时,若一件衣服的水量大于mid,则一件衣服的最短时间是烘干一段时间,在自己蒸发一段时间。可以算出烘干的时间,为(num[i] - mid) / (k - 1)。这样把所有衣服的时间加起来,判断可行即可。

这个就是充分利用的枚举的时间,先把时间减去,再除(k-1)


我自己的想法是,枚举一个时间,用这个时间来除烘干的水分,还有余数,两个加起来和时间进行比较,

后来发现,这样写没有充分利用时间,有可能自由蒸发的时间并没有达到我枚举的时间,所以,得到的就不是最优解。


附上正确代码,看网上题解。

#include <cstdio>  
#include <cstring>  
#include <cmath>  
#include <algorithm>
using namespace std;
long long a[111119];
long long  n;
long long k;
bool judge(long long x){
    long long s,t,y = 0;
    for (int i = 0; i < n; i++){
        if (a[i]>x) {
            long long t = ceil((a[i] - x) * 1.0 / (k - 1));
            y += t;
        }
        }
    if (y <= x) return 1; else return 0;
}
int main() {
    scanf("%lld",&n);
        long long mx = 0;
        for (int i = 0; i < n; i++) {
            scanf("%lld", &a[i]);
            mx = max(mx, a[i]);
        }
      

        scanf("%lld", &k);
    if (k == 1) {
        printf("%lld\n", mx);
        return 0;
    }
        long long l, r, mid, ans;
        l = 0;
        r = mx;
        while (l < r) {
            mid = (l + r) / 2;
            if (judge(mid)) {
                r = mid;
            } else l = mid + 1;
        }
        printf("%lld\n", r);

    return 0;
}

在附上自己错的代码。

#include <bits/stdc++.h>
using namespace std;
using namespace std;
int a[100009];
int n,k;
bool judge(int x){
    int s,t,y = 0;
    for (int i = 0; i < n; i++){
        s = a[i]/k;
        t = a[i]%k;
        y += s;
        if (s+t>x) y++;
    }
    if (y <= x) return 1; else return 0;
}
int main() {
    scanf("%d",&n);
    int mx = 0;
    for (int i = 0; i < n; i++)
    {
        scanf("%d",&a[i]);
        mx = max(mx,a[i]);
    }
    scanf("%d",&k);
    if (k == 1)
    {
        printf("%lld\n",mx);
        return 0;
    }
    int l,r,mid,ans;
    l = 0; r = mx;
    while(l<=r){
        mid=(l+r)/2;
        if (judge(mid)){
            ans = mid;
            r = mid-1;
        } else  l = mid +1;
    }
    printf("%d\n",ans);
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值