XYZZY HDU - 1317 (图论,最长路。spfa )

It has recently been discovered how to run open-source software on the Y-Crate gaming device. A number of enterprising designers have developed Advent-style games for deployment on the Y-Crate. Your job is to test a number of these designs to see which are winnable. 
Each game consists of a set of up to 100 rooms. One of the rooms is the start and one of the rooms is the finish. Each room has an energy value between -100 and +100. One-way doorways interconnect pairs of rooms. 

The player begins in the start room with 100 energy points. She may pass through any doorway that connects the room she is in to another room, thus entering the other room. The energy value of this room is added to the player's energy. This process continues until she wins by entering the finish room or dies by running out of energy (or quits in frustration). During her adventure the player may enter the same room several times, receiving its energy each time. 
InputThe input consists of several test cases. Each test case begins with n, the number of rooms. The rooms are numbered from 1 (the start room) to n (the finish room). Input for the n rooms follows. The input for each room consists of one or more lines containing: 

the energy value for room i 
the number of doorways leaving room i 
a list of the rooms that are reachable by the doorways leaving room i 
The start and finish rooms will always have enery level 0. A line containing -1 follows the last test case. 
OutputIn one line for each case, output "winnable" if it is possible for the player to win, otherwise output "hopeless". 
Sample Input
5
0 1 2
-60 1 3
-60 1 4
20 1 5
0 0
5
0 1 2
20 1 3
-60 1 4
-60 1 5
0 0
5
0 1 2
21 1 3
-60 1 4
-60 1 5
0 0
5
0 1 2
20 2 1 3
-60 1 4
-60 1 5
0 0
-1
Sample Output
hopeless
hopeless
winnable
winnable


从起点走到终点,到每个点的能量必须大于0,如果可以到达终点,则 winnable ,否则, hopeless。

这个题有环,求的是最长路,所以负环不需要考虑,

至于正环,要用spfa 判断正环,就是点的入队次数是不是大于N,如果是,那就把这个点的能量变成很大很大。最后判断到达n点是的能量就行了。

#include <bits/stdc++.h>
using namespace std;
const int INF = 0x3f3f3f3f;
bool vis[200];
int n;
struct node{
    int next,v;
}p[10100];
int head[200],dis[200],g[200],indoor[200];
int sign;
void add_edge(int u, int v){
    sign++;
    p[sign].v = v;
    p[sign].next = head[u];
    head[u] = sign;
}
void spfa(){
    for (int i = 0; i <= n; i++)
        dis[i] = 0,vis[i] = 0,indoor[i] = 0;
    dis[1] = 100;
    queue<int>q;
    while(!q.empty()) q.pop();
    q.push(1);
    vis[1] = 1;
    indoor[1] = 1;
    while(!q.empty()){
        int u = q.front();
        q.pop();
        vis[u] = 0;
        if (indoor[u] > n) continue;
        for (int i = head[u]; i != -1; i = p[i].next ){
            int v = p[i].v, w = g[v];
            if (dis[v] < dis[u] + w){
                dis[v] = dis[u]+w;
                if (vis[v] == 0){
                    vis[v] = 1;
                    q.push(v);
                    indoor[v]++;
                    if (indoor[v] >= n) dis[v] = INF;
                }
            }
        }
    }
    if (dis[n] > 0) printf("winnable\n"); else
        printf("hopeless\n");
    return ;
}
int main() {
    int t,s,m;
    while(scanf("%d",&n)== 1 && n != -1){
        memset(head,-1,sizeof(head));
        sign = 0;
        for (int i = 1; i<= n; i++){
            scanf("%d%d",&g[i],&t);
            for (int j = 0; j < t; j++){
                scanf("%d",&s);
                add_edge(i,s);
            }
        }
        spfa();
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值