2018年蓝桥杯省赛(javaB组)第九题

标题:全球变暖

你有一张某海域NxN像素的照片,“。”表示海洋,“#”表示陆地,如下所示:


.##…
.##…
…##.
…####.
…###.

其中“上下左右”四个方向上连在一起的一片陆地组成一座岛屿。例如上图就有2座岛屿。

由于全球变暖导致了海面上升,科学家预测未来几十年,岛屿边缘一个像素的范围会被海水淹没。具体来说如果一块陆地像素与海洋相邻(上下左右四个相邻像素中有海洋),它就会被淹没。

例如上图中的海域未来会变成如下样子:





…#…

请你计算:依照科学家的预测,照片中有多少岛屿会被完全淹没。

【输入格式】
第一行包含一个整数N.(1 <= N <= 1000)
以下N行N列代表一张海域照片。

照片保证第1行,第1列,第N行,第N列的像素都是海洋。

【输出格式】
一个整数表示答案。

【输入样例】
7

.##…
.##…
…##.
…####.
…###.

【输出样例】
1

使用bfs宽度优先搜索进行

import java.util.LinkedList;
import java.util.Queue;
import java.util.Scanner;

public class quanqiubiannuan{
    static char[][] arr;
    static int[][] map;
    static int N;
    static int res;
    static int[] movex={-1,1,0,0};
    static int[] movey ={0,0,-1,1};
    
        public static class Node{
        int x,y;
        public Node(int x, int y) {
            this.x = x;
            this.y = y;
        }
    }
    
    public static void main(String[] args) {
        Scanner s=new Scanner(System.in);
        N=Integer.parseInt(s.nextLine());
        arr=new char[N][N];
        map=new int[N][N];
        res=0;
        for (int i=0;i<N;i++){
            char[] str= s.nextLine().toCharArray();
            for (int j=0;j<N;j++){
                arr[i][j]=str[j];
            }
        }
        for (int i=0;i<N;i++){
            for (int j=0;j<N;j++){
                if (arr[i][j]=='#'&&map[i][j]==0){
                    bfs(i,j);
                }
            }
        }
        System.out.println(res);
    }

    private static void bfs(int x, int y) {
        map[x][y]=1;
        int land=0;
        int changeland=0;
        Queue<Node> list= new LinkedList<Node>();
        list.add(new Node(x,y));
        while (list.isEmpty()!=true){
            Node node=list.poll();
            land++;
            boolean change=false;
            for (int i=0;i<4;i++){
                int x2=node.x+movex[i];
                int y2=node.y+movey[i];
                if (0<=x2 && x2<N && 0<=y2 && y2<N) {
                    if (arr[x2][y2] == '.') { change = true; }
                    if (arr[x2][y2] == '#' && map[x2][y2] == 0) {
                        list.add(new Node(x2, y2));
                        map[x2][y2] = 1;
                    }
                }
            }
            if (change){ changeland++; }
        }
        if (land==changeland){ res++; }
    }

}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值