Majority ICPC_Pacific Northwest Region Programming Contest基础题

Problem N

— limit 5 seconds

The votes are in! Mathematicians world-wide have been polled, and each has chosen their favorite number between 1 and 1000. Your goal is to tally the votes and determine what the most popular number is.
If there is a tie for the greatest number of votes, choose the smallest number with that many votes.
Input
Input will start with a single line containing the number of test cases, between 1 and 100 inclusive. For each test case, there will be a single line giving the number of votes V , 1 ≤ V ≤ 1000. Following that line will be V lines, each with a single integer vote between 1 and 1000.
Output
Sample Input Sample Output
3 42 37 42 11 42
19
4
7
99
99
7
5
11
12
13
14
15
2014 Pacific Northwest Region Programming Contest—Division 2 5

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
void acc()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
}
int a[1210];
int main()
{
    acc();
    int t;
    cin>>t;
    while(t--)
    {
        int ans =  0, mtime = -1;
        memset(a, 0, sizeof(a));
        int n;
        cin>>n;
        while(n--)
        {
            int x;
            cin >> x;
            a[x]++;
            if(a[x] > mtime)
            {
                ans = x;
                mtime = a[x];
            }
            else if(a[x] == mtime && x < ans)
            {
                ans = x;
            }
        }
        cout<<ans<<endl;
    }
    return  0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值