CF #486 div3 A. Diverse Team(经典数组操作)

A. Diverse Team

Description:

There are n students in a school class, the ratingof the i-th student on Codehorses is ai. You have to form a team consisting of k students (1≤k≤n) such that the ratings of all team members are distinct.

If it is impossible to form a suitable team, print “NO” (without quotes). Otherwise print “YES”, and then print k distinct numbers which should be the indices of students in the team you form. If there are multiple answers, print any of them.

Input:

The first line contains two integers n and k (1≤k≤n≤100) — the number of students and the size of the team you have to form.

The second line contains n integers a1,a2,…,an a_1,a_2,…,a_na (1≤ai a_ia i ≤100), where ai is the rating of i-th student.

Output:

If it is impossible to form a suitable team, print “NO” (without quotes). Otherwise print “YES”, and then print k distinct integers from 1 to n which should be the indices of students in the team you form. All the ratings of the students in the team should be distinct. You may print the indices in any order. If there are multiple answers, print any of them.

Assume that the studesnts are numbered from 1 to n.

Sample Input:

5 3
15 13 15 15 12

Sample Output:

YES
1 2 5

Sample Input:

5 4
15 13 15 15 12

Sample Output:

NO

Sample Input:

4 4
20 10 40 30

Sample Output:

YES
1 2 3 4

题意:找不不同的数标记位置。

#include<bits/stdc++.h>
using namespace std;
const int N = 105;
int vis[N];
int main()
{
    int n,k;
    scanf("%d %d",&n,&k);
    int type=0;
    for(int i=0; i<n; i++)
    {
        int x;
        scanf("%d",&x);
        if(!vis[x])
        {
            vis[x]=i+1;
            type++;
        }
    }
    if(type<k) printf("NO\n");
    else
    {
        printf("YES\n");
        int j=0;
        sort(vis,vis+101);
        for(int i=0; i<=100; i++)
            if(vis[i])
            {
                if(k==1)
                    printf("%d\n",vis[i]);
                else if(k>1)
                    printf("%d ",vis[i]);
                else
                    break;
                k--;
            }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值