hdu1394-Minimum Inversion Number

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit
 
Status
Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj. 


For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following: 


a1, a2, ..., an-1, an (where m = 0 - the initial seqence) 
a2, a3, ..., an, a1 (where m = 1) 
a3, a4, ..., an, a1, a2 (where m = 2) 
... 
an, a1, a2, ..., an-1 (where m = n-1) 


You are asked to write a program to find the minimum inversion number out of the above sequences. 
 
Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1. 
 
Output
For each case, output the minimum inversion number on a single line. 
 
Sample Input
 10
1 3 6 9 0 8 5 7 4 2 
 
Sample Output

 16 



题目大意:给你一段数,然后每次把第一个数放到最后一个位置,求出这样操作后其中最小的逆序数,

逆序数概念(如:4 1 3 2,这段数中有41,43,42,32这四个逆序数,既该排列有总共有4个逆序数 )。


思路:用归并排序求出开始状态的逆序数设为ans。设当前第一个位置的数的与它对应的逆序数有k个,则每次调换位置,总的逆序数为ans = ans - k + (n-1-k)。因为给的数的范围是0-n-1,所以比如当5在第一个位置的时候所有比5

小的数肯定都在5后面 所以5的逆序数有5个 既k等于当前数的大小。


代码:


#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
int a[6000];
int b[6000];
int ans;
void bsort1(int a[],int begin, int mid, int end)
{
    int i = begin;
	int j = mid+1;
	int k = begin;
    while (i<=mid&&j<=end)
	{
	    if(a[i] <= a[j])
		{
		    b[k++] = a[i++];
		}
		else 
		{
		    b[k++] = a[j++];
            ans += mid - i + 1;
		}
	}
	while (i <= mid)
	{
	    b[k++] = a[i++];
	}
	while (j <=end)
	{
	    b[k++] = a[j++];
	}
	for(i = begin; i<= end; i++)
	{
	    a[i] = b[i];
	}
}
void bsort(int a[],int begin,int end)
{
    if(begin < end)
	{
	    int mid = (begin + end)/2;
	    bsort(a,begin,mid);
	    bsort(a,mid+1,end);
	    bsort1(a,begin,mid,end);
	}
	else return;
}
int main()
{
    int n,i,z;
	while (scanf("%d",&n)!=EOF)
	{
		z = 10000000;
		ans = 0;
		memset(a,0,sizeof(a));
		int r[6000];
	    for(i = 1; i <= n;i++)
		{
			scanf("%d",&a[i]);
			r[i] = a[i];
		}
		bsort(a,1,n);
		for(i = 1;i<=n;i++)
		{
		    int k = ans - r[i]  + (n - 1 - r[i]);
			ans = k;
			if(k < z)
				z = k;
		}
		cout<<z<<endl;
	}

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值