hdu-1875-畅通工程再续-最小生成树

畅通工程再续

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14788    Accepted Submission(s): 4570


Problem Description
相信大家都听说一个“百岛湖”的地方吧,百岛湖的居民生活在不同的小岛中,当他们想去其他的小岛时都要通过划小船来实现。现在政府决定大力发展百岛湖,发展首先要解决的问题当然是交通问题,政府决定实现百岛湖的全畅通!经过考察小组RPRush对百岛湖的情况充分了解后,决定在符合条件的小岛间建上桥,所谓符合条件,就是2个小岛之间的距离不能小于10米,也不能大于1000米。当然,为了节省资金,只要求实现任意2个小岛之间有路通即可。其中桥的价格为 100元/米。
 

Input
输入包括多组数据。输入首先包括一个整数T(T <= 200),代表有T组数据。
每组数据首先是一个整数C(C <= 100),代表小岛的个数,接下来是C组坐标,代表每个小岛的坐标,这些坐标都是 0 <= x, y <= 1000的整数。
 

Output
每组输入数据输出一行,代表建桥的最小花费,结果保留一位小数。如果无法实现工程以达到全部畅通,输出”oh!”.
 

Sample Input
  
  
2 2 10 10 20 20 3 1 1 2 2 1000 1000
 

Sample Output
  
  
1414.2 oh!
 

Author
8600
 

Source
 

Recommend
lcy



思路:求出最小生成树并判断是否全部的点都联通,这里不是直接给你哪条路可以联通,而是给你所有点的坐标 让你先求出可以连接的点之后再判断最小生成树

代码:
<span style="font-size:18px;">#include <cstdio>
#include <cstring>
#include <iostream>
#include <cmath>
#include <iostream>
#include <cstdlib>
#include <algorithm>
using namespace std;
struct point
{
    double x, y;
}p[200];

struct E
{
    int u,v;
    double w;
}e[20000];
int cmp(const void *a, const void *b)
{
    if(((E *)a) -> w > ((E *)b)->w)
        return 1;
    else
        return -1;
}
int fa[200],rank[200],nn,count1;
</span><pre name="code" class="html"><span style="font-size:18px;">//并查集</span>
int find(int x){ int q = x; while(q != fa[q]) { q = fa[q]; } int w = x; while (w!= q) { x = fa[w]; fa[w] = q; w = x; } return w;}int uni(int x, int y){ if(x != y) { rank[x] += rank[y]; fa[y] = x; } return rank[x];}
//kruskal求最短路double f(){ int i; qsort(e,count1,sizeof(e[0]),cmp); double ans = 0; for(i = 0; i<count1;i++) { int x = find(e[i].u); int y = find(e[i].v); if(x!=y) { nn = uni(x,y); ans+= e[i].w; } } return ans;}int main(){ int t,n,i,j; cin>>t; while (t--) { cin>>n; nn = 0; count1 = 0; for(i = 1; i<=n;i++) { fa[i] = i; rank[i] = 1; } for(i = 1; i<= n; i++) scanf("%lf %lf",&p[i].x,&p[i].y); for(i = 1; i<=n-1;i++) { for(j = i+1;j <= n; j++) { double x1 = (p[i].x - p[j].x) * (p[i].x - p[j].x); double y1 = (p[i].y - p[j].y) * (p[i].y - p[j].y); if(sqrt(x1+y1)>9.99999999999999&&sqrt(x1+y1)<1000.0000000000000000001) { e[count1].u = i; e[count1].v = j; e[count1++].w = sqrt(x1+y1)*100.0; } } } double a = f(); if(nn < n) { cout<<"oh!"<<endl; } else { printf("%.1lf\n",a); } } return 0;}
 
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值