poj3268-Silver Cow Party


A - Silver Cow Party
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit Status Practice POJ 3268

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input
Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output
Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint
Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.



题目大意:一群牛去聚会,每头牛都住在自己的农场,总共有n个农场,就是有n头牛,要去目的地x,然后结束以后再返回自己的农场,但是每条路都是单向的,所以来回的路可能不一样。但是每头牛去x和回自己的农场都是走最短路,问用时最久的那头牛用了多长时间


思路用dij求两次最短路就行,第一次求x到每个点的最短路,第二次把路反过来在求一次x到每个点的最短路,两次结果相加最大的就是最后答案了



邻接表dij代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#include <algorithm>
#include <cstdlib>
using namespace std;

const int maxn = 22222222;

int n,m,x,head[1100],vis[1100],d[1100][2],cnt,l[110000][3];

struct Edge
{
    int u,v,w,next;
    Edge(int a=0, int b=0, int c=0)
    {
        u = a; v = b; w = c;
    }
}e[110000];

struct node
{
    int vis,val;
    friend bool operator <(node a, node b)
    {
        return a.val >b.val;
    }
    node (int x = 0, int y = 0)
    {
        vis = x;
        val =y;
    }
};

void add(Edge q)
{
    e[cnt].u = q.u;
    e[cnt].v = q.v;
    e[cnt].w = q.w;
    e[cnt].next = head[q.u];
    head[q.u] =cnt++;
}

void dij(int st,int c)
{
    memset(vis,0,sizeof(vis));
    int i;
    for(i = 0; i<=n;i++)
    {
        d[i][c] = maxn;
    }
    d[st][c] = 0;
    priority_queue<node> q;
    q.push(node (st,d[st][c]));
    while (!q.empty())
    {
        node w = q.top();
        q.pop();
        if(vis[w.vis] == 1)
        {
            continue;
        }
        vis[w.vis] = 1;
        int begin = w.vis;
        for(i = head[begin];i!=-1;i = e[i].next)
        {
            int end = e[i].v;
            if(d[end][c] > d[begin][c] + e[i].w)
            {
                d[end][c] = d[begin][c] + e[i].w;
                q.push(node (end,d[end][c]));
            }
        }
    }
}

int main()
{
    int i,j;
    while (scanf("%d %d %d",&n,&m,&x)!=EOF)
    {
        cnt = 0;
        memset(head,-1,sizeof(head));
        for( i = 0; i < m; i++)
        {
            scanf("%d %d %d",&l[i][0],&l[i][1],&l[i][2]);
            add(Edge(l[i][0],l[i][1],l[i][2]));
        }
        dij(x,0);
        cnt = 0;
        memset(head,-1,sizeof(head));
        for( i = 0; i < m; i++)
        {
            add(Edge(l[i][1],l[i][0],l[i][2]));
        }
        dij(x,1);
        int ans = -1;
        for(i = 0; i <= n;i++)
        {
            if(d[i][0] + d[i][1] >ans&&d[i][0]!=maxn&&d[i][1]!=maxn)
            {
                ans = d[i][0] + d[i][1] ;
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}

邻接矩阵代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#include <algorithm>
#include <cstdlib>
using namespace std;

const int maxn = 22222222;

int n,m,x,vis[1100],d[1100][2],l[110000][3],w[1100][1100];

void dij(int st,int c)
{
    memset(vis,0,sizeof(vis));
    int i,j;
    for(i = 0; i<=n;i++)
    {
        d[i][c] = maxn;
    }
    d[st][c] = 0;
    for(i = 1;i<=n;i++)
    {
        int x, y = maxn;
        for(j = 1; j <= n; j++)
        {
            if(vis[j] == 0&&d[j][c]<y)
            {
                y = d[j][c];
                x = j;
            }
        }
        vis[x] = 1;
        for(j = 1; j<=n;j++)
        {
            d[j][c] = min(d[j][c],d[x][c] + w[x][j]);
        }
    }
}

int main()
{
    int i,j;
    while (scanf("%d %d %d",&n,&m,&x)!=EOF)
    {
        memset(w,1,sizeof(w));
        for( i = 0; i < m; i++)
        {
            scanf("%d %d %d",&l[i][0],&l[i][1],&l[i][2]);
            w[l[i][0]][l[i][1]] = l[i][2];
        }
        dij(x,0);
        memset(w,1,sizeof(w));
        for( i = 0; i < m; i++)
        {
            w[l[i][1]][l[i][0]] = l[i][2];
        }
        dij(x,1);
        int ans = -1;
        for(i = 0; i <= n;i++)
        {
            if(d[i][0] + d[i][1] >ans&&d[i][0]!=maxn&&d[i][1]!=maxn)
            {
                ans = d[i][0] + d[i][1] ;
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值