hdu-1142-- A Walk Through the Forest

Time Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Description

Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable.
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take.
 

Input

Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections.
 

Output

For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647
 

Sample Input

     
     
5 6 1 3 2 1 4 2 3 4 3 1 5 12 4 2 34 5 2 24 7 8 1 3 1 1 4 1 3 7 1 7 4 1 7 5 1 6 7 1 5 2 1 6 2 1 0
 

Sample Output

2

4

题目大意:起点为1,终点为2的一条路要你求出所有满足条件的路有多少条,条件是如果当前站的位置为a,下一步为b的话a,b必须满足a到终点的最小距离大于b到终点的最小距离,则a可以走到b

思路 :直接用dij预处理一下终点2到所有点的最短距离,然后dfs记忆化搜索所有可以到达的点


代码 :

#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <iostream>
#include <queue>
#include <algorithm>
typedef long long LL;
using namespace std;
LL maxn = 222222222;
int vis[1100],head[1100],cnt,flag[1100],n,m;
LL d[1100],dp[1100];
struct Edge
{
    int u,v,next;
    LL w;
    Edge(int a =0, int b = 0, LL c = 0)
    {
        u = a; v = b; w = c;
    }
}e[1000001];
void add(Edge q)
{
    e[cnt].u = q.u;
    e[cnt].v = q.v;
    e[cnt].w = q.w;
    e[cnt].next = head[q.u];
    head[q.u] = cnt++;
}
struct node
{
    int vis;
    LL val;
    friend bool operator <(node a, node b)
    {
        return a.val >b.val;
    }
    node (int a = 0, LL b = 0)
    {
        vis = a; val = b;
    }
};
void dij(int st)
{
    memset(vis,0,sizeof(vis));
    int i;
    for(i = 1; i<=n; i++)
    {
        d[i] = maxn;
    }
    d[st] = 0;
    priority_queue <node> q;
    q.push(node (st,d[st]));
    while (!q.empty())
    {
        node w = q.top();
        q.pop();
        int begin = w.vis;
        if(vis[begin] == 1)
        {
            continue;
        }
        vis[begin] = 1;
        for(i = head[begin];i!=-1;i = e[i].next)
        {
            int end = e[i].v;
            if(d[end] > d[begin] + e[i].w)
            {
                d[end] = d[begin] + e[i].w;
                q.push(node (end,d[end]));
            }
        }
    }
}
LL dfs(int begin)
{
    if(begin == 2)
    {
        return 1;
    }
    if(flag[begin] == 1)
    {
        return dp[begin];
    }
    flag[begin] = 1;
    dp[begin] = 0;
    int i;
    for(i = head[begin]; i!=-1; i=e[i].next)
    {
        int end = e[i].v;
        if(d[end] < d[begin])
        {
            dp[begin] += dfs(end);
        }
    }
    return dp[begin];
}
int main()
{
    int i,a,b,c;
    while (scanf("%d",&n)&&n)
    {
        cin>>m;
        memset(head,-1,sizeof(head));
        cnt =0;
        for(i = 0; i < m ;i++)
        {
            scanf("%d %d %d",&a,&b,&c);
            add(Edge(a,b,c));
            add(Edge(b,a,c));
        }
        memset(flag,0,sizeof(flag));
        dij(2);
        LL ans = dfs(1);
        printf("%I64d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值