2015-11-11 hdu新生赛 E题(结束后一发AC)

Problem E

Time Limit : 3000/2000ms (Java/Other)   Memory Limit : 65535/65535K (Java/Other)
Total Submission(s) : 98   Accepted Submission(s) : 33
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

A magic number is a number formed by concatenation of numbers 1, 14 and 144. We can use each of these numbers any number of times. Therefore 14144, 141414 and 1411 are magic numbers but 1444, 514 and 414 are not.

You're given a number. Determine if it is a magic number or not.

Input

The first line of input contains an integer n, (1≤n≤10^13). This number doesn't contain leading zeros.

Output

Print "YES" if n is a magic number or print "NO" if it's not.

Sample Input

114114
1111
441231

Sample Output

YES
YES
NO
 
 
————————————————————————————————————————————————————————————————————
 
 
(ps:又在学霸室友的指导下AC了。。%%%)
 
 
1.直接见代码吧,就是144,14,1扫一遍
 
 
代码如下:
#include <stdio.h>
#include <string.h>
int main(){
int i,sum;
char s[100]; 
while(scanf("%s",s)!=EOF){
sum=0;
for(i=0;i<strlen(s);)
{
	if(s[i]=='1'&&s[i+1]=='4'&&s[i+2]=='4') {i=i+3; sum+=3;}
	else if(s[i]=='1'&&s[i+1]=='4') {i=i+2;sum+=2;}
	else if(s[i]=='1') {i=i+1;sum++;}
	else break;
}
if(sum==strlen(s)) printf("YES\n");
else printf("NO\n");
}




    return 0;
}
 
 
大一新生acm,方法可能不好,希望大神指点奋斗,不喜勿喷。
 
 
人一我百,人十我万!!!


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值