玲珑杯 I -- I am Two

I -- I am Two

Time Limit:1s Memory Limit:64MByte

Submissions:506Solved:198

DESCRIPTION

Check whether an integer n is a power of 2.

INPUT
First line contains a single integer T (T<=20) which denotes the number of test cases. For each test case, there is an 32-bit integer N .
OUTPUT
For each case, output the "Yes" or "No" in a single line.
SAMPLE INPUT
3138
SAMPLE OUTPUT
YesNoYes
SOLUTION
水题,打个表判断
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define inf 0x6fffffff
#define LL long long
using namespace std;
LL a[50];
int main(){
    int t;
    cin>>t;
    a[0]=1;
    for(int i=1;i<=31;i++){
        a[i]=a[i-1]*2;
    }
    while(t--){
        int n,k=0;
        cin>>n;
        for(int i=0;i<=30;i++){
            if(a[i]==n)k=1;
        }
        if(k)cout<<"Yes"<<endl;
        else cout<<"No"<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值