poj 2115 (扩展欧几里得,二元不等式求解)

C Looooops
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 24807 Accepted: 7007

Description

A Compiler Mystery: We are given a C-language style for loop of type 
for (variable = A; variable != B; variable += C)

  statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2 k) modulo 2 k

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2 k) are the parameters of the loop. 

The input is finished by a line containing four zeros. 

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate. 

Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766
FOREVER

Source

CTU Open 2004


题中很容易看出是求函数  A+xC=B(mod 2^k)中x的最小值,我们可以化简为 xC=B-A(mod 2^k)---》C*x+2^k*y=B-A

我们使a=C,b=2^k,c=B-A,也就是ax+by=c;

然后就是扩展欧几里得求出x的值,如果!gcd(C,2^k)| (B-A),说明没有解,证明的话  点这里

之后求出的x还不是最终的答案,因为我们要求最小值,所以最后 x=x*c/gcd(a,b),     x=(x%t+t)%t (t=b/gcd(a,b))


代码


#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <stack>
#include <map>
#include <set>
#include <vector>
#include <queue>
#define mem(p,k) memset(p,k,sizeof(p));
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define inf 0x6fffffff
#define LL long long
#define MAXN 20000
using namespace std;
LL extended_gcd(LL a,LL b,LL &x,LL &y)  //?????????
{  
            LL ans,t;  
            if (b==0) { x=1; y=0; return a; }  
            else { ans=extended_gcd(b,a%b,x,y); t=x; x=y; y=t-(a/b)*y;}  
            return ans;  
}  
void exgcd(LL m,LL n,LL &x,LL &y){//  ?????????

    LL x1,y1,x0,y0;
    x0=1,y0=0;
    x1=0,y1=1;
    LL r=(m%n+n)%n;
    LL q=(m-r)/n;
    x=0;
    y=1;
    while(r){
        x=x0-q*x1;
        y=y0-q*y1;
        x0=x1;
        y0=y1;
        x1=x;
        y1=y;
        m=n,n=r,r=m%n;
        q=(m-r)/n;
    }
    return ; 
}
LL kabs(LL a){
	return a>0?a:-a;
}
int main(){
    LL a,b,c,d,g,x,y,n1,n2,n3,n4;
    while(cin>>n1>>n2>>n3>>n4&&(n1||n2||n3||n4)){
        n4=(LL)1<<n4;
        a=n3,b=n4,c=n2-n1;
        g=extended_gcd(a,b,x,y);
        if(c%g){
            printf("FOREVER\n");
            continue;
        }
        else{
            x=x*c/g%n4;
            LL t=kabs(b/g);
            x=(x%t+t)%t;
            //if(!x)x+=t;
            printf("%lld\n",x);
        }
    }
    
    
    
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值