poj 3259 (SPFA,求是否有负权回路)

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2..  M+1 of each farm: Three space-separated numbers (  SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2..  MW+1 of each farm: Three space-separated numbers (  SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back T seconds.
Output
Lines 1..  F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES

代码:


#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <stack>
#include <map>
#include <set>
#include <vector>
#include <queue>
#define mem(p,k) memset(p,k,sizeof(p));
#define rep(i,j,k) for(int i=j; i<k; i++)
#define pb push_back
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define inf 0x6fffffff
#define ll long long
using namespace std;
const int mod=1e9+7;
struct SD{
    int x,y;
    ll l;
    bool operator <(const struct SD &a)const{
       return l>a.l;
    }
}st[210],p;
char s[2100];
int bk[510],f[50000],out[510],dis[510];
int n,m,k,minn,maxx,ans,cur,sum,x,y;
int nex[4][2]={0,1,1,0,0,-1,-1,0};
vector<struct SD> a[510];
queue<int> q;
int bfs(struct SD s){
    while(q.size())q.pop();
    rep(i,1,n+1)dis[i]=inf,bk[i]=0,out[i]=0;
    q.push(s.x);
    bk[s.x]=1;
    dis[s.x]=0;
    while(q.size()){
        int t=q.front();//cout<<t<<endl;
        q.pop();
        bk[t]=0;
        out[t]++;
        if(out[t]>n){
                return 1;
        }
        int le=a[t].size();
        rep(i,0,le){
           int yy=a[t][i].y,l=a[t][i].l;
           if(dis[yy]>dis[t]+l){
               dis[yy]=dis[t]+l;
               if(!bk[yy]){
                 bk[yy]=1;
                 q.push(yy);
               }
           }
        }
    }
//    for(int i=1;i<=n;i++){
//        cout<<i<<'='<<dis[i]<<endl;
//    }
    return 0;
}
int main()
{
    int t;
    cin>>t;
    while(t--){
        cin>>n>>m>>k;
        rep(i,0,n+1)a[i].clear();
        rep(i,0,m){
            scanf("%d%d%lld",&p.x,&p.y,&p.l);
            a[p.x].pb(p);
            swap(p.x,p.y);
            a[p.x].pb(p);
        }
        rep(i,0,k){
            scanf("%d%d%lld",&p.x,&p.y,&p.l);
            p.l=-p.l;
            st[i]=p;
            a[p.x].pb(p);
//            swap(p.x,p.y);
//            a[p.x].pb(p);
        }
        cur=0;
        rep(i,0,k){
            if(bfs(st[i])){
                cur=1;break;
            }
        }
        if(cur)cout<<"YES"<<endl;
        else cout<<"NO"<<endl;
    }


    return 0;
}
//freopen("C:\\Users\\LENOVO\\Desktop\\read.txt","r",stdin);



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值