POJ 1160 Post Office (区间DP+重心)

Post Office
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 19868 Accepted: 10676

Description

There is a straight highway with villages alongside the highway. The highway is represented as an integer axis, and the position of each village is identified with a single integer coordinate. There are no two villages in the same position. The distance between two positions is the absolute value of the difference of their integer coordinates. 

Post offices will be built in some, but not necessarily all of the villages. A village and the post office in it have the same position. For building the post offices, their positions should be chosen so that the total sum of all distances between each village and its nearest post office is minimum. 

You are to write a program which, given the positions of the villages and the number of post offices, computes the least possible sum of all distances between each village and its nearest post office. 

Input

Your program is to read from standard input. The first line contains two integers: the first is the number of villages V, 1 <= V <= 300, and the second is the number of post offices P, 1 <= P <= 30, P <= V. The second line contains V integers in increasing order. These V integers are the positions of the villages. For each position X it holds that 1 <= X <= 10000.

Output

The first line contains one integer S, which is the sum of all distances between each village and its nearest post office.

Sample Input

10 5
1 2 3 6 7 9 11 22 44 50

Sample Output

9

题意:在一条直线上有N个城镇,现在在这N个城镇中选M个邮局,求每个城镇到最近的邮局之和最小。

分析:由重心性质可知,如果在多个城镇建一个邮局,建在重心位置的城镇的邮局之距离和最小。由此可以想到DP思路。

DP【i】【j】表示在第 1 个到第 j 个城镇之间建立i个城镇的最小距离和。

DP【i】【j】=DP【i-1】【k-1】+len【k】【j】(len【k】【j】表示在第k~j城镇中建立一个邮局的最小距离和)


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <stack>
#include <map>
#include <set>
#include <vector>
#include <queue>
#define mem(p,k) memset(p,k,sizeof(p));
#define rep(a,b,c) for(int a=b;a<c;a++)
#define pb push_back
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define inf 0x6fffffff
#define ll long long
using namespace std;
ll dp[31][310],a[310],len[310][310];
int main()
{
    int n,m;
    scanf("%d%d",&n,&m);
    mem(dp,-1);
    for(int i=1;i<=n;i++)scanf("%lld",a+i);
    for(int i=1;i<=n;i++){
        for(int j=i;j<=n;j++){
            if(i==j)len[i][j]=0;
            else len[i][j]=len[i][j-1]+a[j]-a[(j+i)/2];
            if(i==1)dp[1][j]=len[1][j];
        }
    }
//    while(1){int a,b;
//        scanf("%d%d",&a,&b);cout<<len[a][b]<<endl;
//    }
    for(int i=2;i<=m;i++){
        for(int j=i;j<=n;j++){
            for(int k=i;k<=j;k++){
                dp[i][j]=min(dp[i][j]<0?inf:dp[i][j],dp[i-1][k-1]+len[k][j]);
            }
        }
    }
    cout<<dp[m][n]<<endl;
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值