数位拆解---特殊乘法
时间限制:1 秒
内存限制:32 兆
题目来源: 2010年清华复试
题目描述:
写个算法,对2个小于1000000000的输入,求结果。
特殊乘法举例:123 * 45 = 1*4 +1*5 +2*4 +2*5 +3*4+3*5
输入:
两个小于1000000000的数
输出:
输入可能有多组数据,对于每一组数据,输出Input中的两个数按照题目要求的方法进行运算后得到的结果。
样例输入:
123 45
样例输出:
54
思路一:将输入的两个数字进行数位拆解后存放在两个不同的数组里,用两个变量cnt1和cnt2记录拆解的位数,最后通过两层for循环完成乘法操作。
AC代码:
#include<cstdio>
using namespace std;
char str1[15],str2[15];
int main(){
int a,b;
while(scanf("%d%d",&a,&b)!=EOF){
if(a==0 || b==0)
printf("0"); //输入有一个是0的时候,对0是无法进行数位拆解的,特殊处理一下。
int cnt1 = 0,cnt2=0;
while(a!=0){
str1[cnt1++]=a%10;
a/=10;
}
while(b!=0){
str2[cnt2++]=b%10;
b/=10;
}
int ans = 0;
for(int i=0;i<cnt1;i++)
for(int j=0;j<cnt2;j++)
ans+=str1[i]*str2[j];
printf("%d\n",ans);
}
return 0;
}
思路二(处理字符的方法),结束标志用str[i]=='\0'或str[i]==0都可以,因为'\0'对应的asc码值就是0,此外字符型的数字要转成成其对应的整型值时,直接减去字符'0'即可。
AC代码:
#include<cstdio>
using namespace std;
char str1[15],str2[15];
int main(){
while(scanf("%s%s",str1,str2)!=EOF)
{
int ans = 0;
for(int i=0;str1[i]!='\0';i++)
for(int j=0;str2[j]!='\0';j++)
ans+=(str1[i]-'0')*(str2[j]-'0');
printf("%d\n",ans);
return 0;
}
}