Curling 2.0

Problem Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.


Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

  • At the beginning, the stone stands still at the start square.
  • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
  • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
  • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
    • The stone hits a block (Fig. 2(b), (c)).
      • The stone stops at the square next to the block it hit.
      • The block disappears.
    • The stone gets out of the board.
      • The game ends in failure.
    • The stone reaches the goal square.
      • The stone stops there and the game ends in success.
  • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.


Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).


Fig. 3: The solution for Fig. D-1 and the final board configuration

 

Input
<p>The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.</p><p>Each dataset is formatted as follows.</p><blockquote><p><i>the width(=w) and the height(=h) of the board</i> <br><i>First row of the board</i> <br>... <br><i>h-th row of the board</i></p></blockquote><p>The width and the height of the board satisfy: 2 <= <i>w</i> <= 20, 1 <= <i>h</i> <= 20.</p><p>Each line consists of <i>w</i> decimal numbers delimited by a space. The number describes the status of the corresponding square.</p><blockquote><table id="table1"><tr><td>0 </td><td>vacant square</td></tr><tr><td>1 </td><td>block</td></tr><tr><td>2 </td><td>start position</td></tr><tr><td>3 </td><td>goal position</td></tr></table></blockquote><p>The dataset for Fig. D-1 is as follows:</p><blockquote><p>6 6 <br>1 0 0 2 1 0 <br>1 1 0 0 0 0 <br>0 0 0 0 0 3 <br>0 0 0 0 0 0 <br>1 0 0 0 0 1 <br>0 1 1 1 1 1</p></blockquote>
 

Output
<p>For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.</p>
 

Sample Input
  
  
2 1 3 2 6 6 1 0 0 2 1 0 1 1 0 0 0 0 0 0 0 0 0 3 0 0 0 0 0 0 1 0 0 0 0 1 0 1 1 1 1 1 6 1 1 1 2 1 1 3 6 1 1 0 2 1 1 3 12 1 2 0 1 1 1 1 1 1 1 1 1 3 13 1 2 0 1 1 1 1 1 1 1 1 1 1 3 0 0
 

Sample Output
  
  
1 4 -1 4 10 -1
 

    咋一看到这个题的感觉是他怎么这么长这么长!这么长的英文,还配这么多图!然后开始读题,还好,虽说题目长了点,意思多了点,但题意说的还是挺清楚的。首先,你有一个冰壶,地图上 0是路、1是墙、2是起点、3是终点,没毛病。怎么玩法呢,冰壶可以上下左右推动,条件是如果该方向上冰壶紧挨着的那个点是路(当然是终点就更好了),这个运动条件很重要的。然后冰壶动了之后呢,要么就一直走走出地图,要么碰到一个墙,碰墙不是说冰壶到墙上了,是他俩挨着了,想一下人撞墙了的样子。撞墙之后:1.冰壶停下来不动了,  2.墙会消失掉。这个撞墙后果也很重要,弄清楚这个才能做题。

    题目让求的是:是否能在10次以内到终点,能够的话输出最少步数,不能输出-1。最短路径,看上去好像是广搜的样子,但是想一想这题涉及到一个地图的变化,不同方向撞不同的墙,得到的地图也不一样啊,总不能给每个节点都配一个地图吧。所以我觉得广搜不能做(起码我不会),用深搜的话,回溯就能很好的解决这个问题。

代码如下:


#include<cstring>
#include<stdio.h>
#include<iostream>
using namespace std;
int n,m,si,sj;
int p[25][25];
int mint,flag;
int dxy[5][2]={{0,0},{-1,0},{0,-1},{1,0},{0,1}};
                    //上     左     下    右
int ok(int x,int y)
{
    if(x>=1&&x<=n && y>=1&&y<=m)
        return 1;
    return 0;
}
void ioan(int x,int y,int t)  //在(x,y),已经发球 t次了
{
    if(t>9)//如果时间大于 10  结束
    {
        flag=2;
        return ;
    }
    p[x][y]=0;
    int xx,yy;
    int time=t+1;//第time次 开球
 //   cout<<endl<<"******  T= "<<time<<endl;
    for(int k=1;k<5;k++)//s四个方向
    {
        xx=x+dxy[k][0];
        yy=y+dxy[k][1];
        if(ok(xx,yy))//如果临点不越界
        {
       //     cout<<"k= "<<k<<endl;
            if(p[xx][yy]==3)//如果到终点了,求时间最小值mint
            {
                if(mint>time)
                    mint=time;
                return ;
            }
            if(p[xx][yy]==0)//有路 向下走
            {
                while(p[xx][yy]==0 && ok(xx,yy))//知道没路点停下
                {
                    xx+=dxy[k][0];
                    yy+=dxy[k][1];
                }
                if(ok(xx,yy) && p[xx][yy]==3)//如果是终点
                {
                    if(mint>time)
                        mint=time;
                    return ;
                }
                if(ok(xx,yy) && p[xx][yy]==1)//如果是墙
                {
                    int xxx=xx-dxy[k][0]; //墙前点停下
                    int yyy=yy-dxy[k][1];
             //       cout<<"("<<xxx<<","<<yyy<<")  ";
                    p[xx][yy]=0;            //墙变为路
                    ioan(xxx,yyy,time);
                    p[xx][yy]=1;
                }
            }
        }
    }
}
int main()
{
    //freopen("D:\\aaa.txt","r",stdin);
    while(cin>>m>>n && (m+n))
    {
        mint=999999;
        flag=0;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                cin>>p[i][j];
                if(p[i][j]==2)
                {
                    si=i;   sj=j;
                }
            }
        }
        ioan(si,sj,0);
        if(mint==999999)
            cout<<"-1"<<endl;
        else
            cout<<mint<<endl;
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值