Truck History

Problem Description
Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on. 

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 
1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that t o is the original type and t d the type derived from it and d(t o,t d) is the distance of the types. 
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 
 

Input
The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.
 

Output
For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.
 

Sample Input
  
  
4 aaaaaaa baaaaaa abaaaaa aabaaaa 0
 

Sample Output
  
  
The highest possible quality is 1/3.

      题意难懂,说的模糊,还有这么大一个像是公式的东西把人吓到了。其实就是说给n个长度为7的字符串,代表车,从一个车改造到另一个车的花费相当于两种车不同的字符数。让求生成所有的车最小花费。做法是求出来每两个车的花费,在求最小生成树,ok了。

代码如下:

#if 0                                  //Prim 求最小生成树

#include<iostream>
#include<string>
#include<cstring>
using namespace std;
int n;
string s[2010];
int edge[2010][2010];
int comp(int x,int y)
{
    int sum=0;
    for(int i=0;i<7;i++)
    {
        if(s[x][i]!=s[y][i])
            sum++;
    }
    edge[x][y]=sum;
    edge[y][x]=sum;
    return sum;
}

int ioan()
{
    int K=n;
    int sum=0;
    int minn[2010];
    int vis[2010]={0};
    memset(minn,0x7f,sizeof(minn));
    minn[1]=0;
    for(int i=1;i<=K;i++)
    {
        int k=0;
        for(int j=1;j<=K;j++)
        {
            if(!vis[j] && minn[j]<minn[k])
                k=j;
        }
        vis[k]=1;
        sum+=minn[k];
        for(int j=1;j<=K;j++)
        {
            if(!vis[j] && edge[k][j]<minn[j])
                minn[j]=edge[k][j];
        }
    }
    return sum;
}
int main()
{
    while(cin>>n && n)
    {
        for(int i=1;i<=n;i++)
        {
            cin>>s[i];
            for(int j=1;j<=i;j++)
            {
                comp(i,j);
            }
        }
        int ans=ioan();
        cout<<"The highest possible quality is 1/"<<ans<<"."<<endl;
    }

    return 0;
}


#endif // 1



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值