POJ-3050

The cows play the child's game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes. 

They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited). 

With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201). 

Determine the count of the number of distinct integers that can be created in this manner.
Input
* Lines 1..5: The grid, five integers per line
Output
* Line 1: The number of distinct integers that can be constructed
Sample Input
1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 2 1
1 1 1 1 1
Sample Output
15
Hint
OUTPUT DETAILS: 
111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111, and 212121 can be constructed. No other values are possible.

      求排列总数,地图大小给定5*5,长度给定6。走过的点可以再走,不标记,这就容易跑起来死循环。注意把return放对位置就ok了。每次结果的话直接用数组标记就好,我用的map多余,因为也就6位数,没必要。

代码如下:

#include<iostream>
#include<cstring>
#include<stdio.h>
#include<map>
using namespace std;
int mp[5][5];
int vk[5][5][4];
map<int,int>vis;
int ans,t,sum;
int dxy[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
int ok(int x,int y)
{
    if(x>=0&&x<5 && y>=0&&y<5)
        return 1;
    return 0;
}
void dfs(int x,int y)
{
    for(int k=0;k<4;k++)
    {
        int xx=x+dxy[k][0];
        int yy=y+dxy[k][1];
        if(ok(xx,yy))
        {
            if(t==5)
            {
                if(vis[ans]==0)
                {
                    sum++;
                    vis[ans]=1;
                }
                return ;
            }
            int pre=ans;
            ans=pre*10+mp[xx][yy];
            t++;
            dfs(xx,yy);
            ans=pre;
            t--;
        }
    }
}
int main()
{
    char ch;
    while(cin>>ch)
    {
        vis.clear();
        mp[0][0]=ch-'0';
        for(int i=1;i<5;i++)
        {
            cin>>ch;
            mp[0][i]=ch-'0';
        }
        for(int i=1;i<5;i++)
        {
            for(int j=0;j<5;j++)
            {
                cin>>ch;
                mp[i][j]=ch-'0';
            }
        }
        sum=0;
        for(int i=0;i<5;i++)
        {
            for(int j=0;j<5;j++)
            {
                memset(vk,0,sizeof(vk));
                ans=mp[i][j];

                t=0;
                dfs(i,j);
            }
        }
        cout<<sum<<endl;

    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值