Largest Submatrix of All 1’s

Largest Submatrix of All 1’s

Time Limit : 10000/5000ms (Java/Other)   Memory Limit : 262144/131072K (Java/Other)
Total Submission(s) : 42   Accepted Submission(s) : 21
Problem Description

Given a m-by-n (0,1)-matrix, of all its submatrices of all 1’s which is the largest? By largest we mean that the submatrix has the most elements.

 

Input
<p>The input contains multiple test cases. Each test case begins with <i>m</i> and <i>n</i> (1 ≤ <i>m</i>, <i>n</i> ≤ 2000) on line. Then come the elements of a (0,1)-matrix in row-major order on <i>m</i> lines each with <i>n</i> numbers. The input ends once EOF is met.</p>
 

Output
<p>For each test case, output one line containing the number of elements of the largest submatrix of all 1’s. If the given matrix is of all 0’s, output 0.</p>
 

Sample Input
  
  
2 2 0 0 0 0 4 4 0 0 0 0 0 1 1 0 0 1 1 0 0 0 0 0
 

Sample Output
  
  
0 4
 
      开始以为这是广搜的题呢,广搜有一个求细胞的题很经典,但后来发现不是,让求最大矩形。
      入手点是搞清楚矩形的最重要的因素:宽和高。我们以每一行为底边来看,很显然向上连续1的个数就是高,那么宽怎么求呢?我们再把每一列假设为边长为1,那么这一列就像是一个小矩形条对不对?想象一下,如果想象不出来,看一下这个题: 点击打开链接  是不是让我们求一个能分割下来的最大的矩阵?只要对每一行都操作一遍就能求出来结果。
      方法的话,单调栈向左向右求第一个小于(矮于)自己的点,高乘以底边长的面积,找出面积最大值就可以了。
      这里每行的每个点的高,处理的时候稍微注意一点,恩,判断一下自己,不用判断之前的了。如果自己是0的话不管之前什么样没了,只有自己是1的情况下才要考虑之前的高度,而说考虑的话,直接加下来就好了,不管原来是0还是1234567,直接加下来和判断不都一个样么?

代码如下:

#include<iostream>
#include<cstring>
#include<stdio.h>
using namespace std;
int main()
{
    int p[2010];
    int h[2010];
	int l[2010];
	int r[2010];
	int s[2010];
    int N,M;
    int Max;
    while(~scanf("%d%d",&N,&M) && N && M)
    {
        Max=0;
        memset(p,0,sizeof(p));
        memset(h,0,sizeof(h));
        memset(s,0,sizeof(s));
        for(int k=1;k<=M;k++)
        {
            for(int j=1;j<=N;j++)
            {
                scanf("%d",&p[j]);
                if(p[j]==0)
                    h[j]=0;
                else
                    h[j]+=p[j];
                l[j]=j;
                r[j]=j;
            }
		int top=0;
		for(int i=1;i<=N;i++)   //向左找
		{
			while(top && h[i]<=h[s[top]])
                top--;
            if(top==0)
                l[i]=1;
            else
                l[i]=s[top]+1;//s[top]存的数的值肯定是比a[i]小的,所以地s[top]+1个位置即为所求
            s[++top]=i;
		}
		top=0;
		for(int i=N;i>=1;i--)
		{
			while(top && h[i]<=h[s[top]])
                top--;
            if(top==0)
                r[i]=N;
            else
                r[i]=s[top]-1;
            s[++top]=i;
		}
		int maxn=0;
		int area;
		for(int i=1;i<=N;i++)
		{
			area=h[i]*(r[i]-l[i]+1);
			if(maxn<area)
				maxn=area;
		}
		if(Max<maxn)
            Max=maxn;
        }
        printf("%d\n",Max);
    }

    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
用C语言解决下列问题:Kirill wants to weave the very beautiful blanket consisting of n&times;m of the same size square patches of some colors. He matched some non-negative integer to each color. Thus, in our problem, the blanket can be considered a B matrix of size n&times;m consisting of non-negative integers. Kirill considers that the blanket is very beautiful, if for each submatrix A of size 4&times;4 of the matrix B is true: A11⊕A12⊕A21⊕A22=A33⊕A34⊕A43⊕A44, A13⊕A14⊕A23⊕A24=A31⊕A32⊕A41⊕A42, where ⊕ means bitwise exclusive OR Kirill asks you to help her weave a very beautiful blanket, and as colorful as possible! He gives you two integers n and m . Your task is to generate a matrix B of size n&times;m , which corresponds to a very beautiful blanket and in which the number of different numbers maximized. Input The first line of input data contains one integer number t (1≤t≤1000 ) — the number of test cases. The single line of each test case contains two integers n and m (4≤n,m≤200) — the size of matrix B . It is guaranteed that the sum of n⋅m does not exceed 2⋅105 . Output For each test case, in first line output one integer cnt (1≤cnt≤n⋅m) — the maximum number of different numbers in the matrix. Then output the matrix B (0≤Bij<263) of size n&times;m . If there are several correct matrices, it is allowed to output any one. It can be shown that if there exists a matrix with an optimal number of distinct numbers, then there exists among suitable matrices such a B that (0≤Bij<263) .
03-10

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值