HDU - 1686 Oulipo (KMP)

                                             Oulipo

Problem Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3

BAPC

BAPC

AZA

AZAZAZA

VERDI

AVERDXIVYERDIAN

Sample Output

1

3

0

题意描述:
求出字符串A在字符串B中出现的次数。

解题思路:

利用kmp算法;先求出字符串A的next[]数组,用kmp算法在B当找到A数量加一,将j更新为next[j-1]继续查找。

KMP算法讲解:https://www.bilibili.com/video/av3246487?from=search&seid=17974959124889101719

#include<stdio.h>
#include<string.h>
int main()
{
	char a[1000005],b[10005];
	int i,j,next[10005],lena,lenb,num,t;
	while(scanf("%d\n",&t)!=EOF)
	{
		while(t--)
		{
			gets(b); 
			gets(a);
			lena=strlen(a);
			lenb=strlen(b);
			j=0;
			next[0]=0;
			//子串next数组求法 
			for(i=1;i<=lenb-1;)
			{
				if(j==0&&b[j]!=b[i])//当j等于0,b[i]与b[j]不相等时,i向后查,next[i]=0 
				{
					next[i]=0;
					i++;
				}
				if(b[i]==b[j])//相等时,i,j都向后走 
				{
					next[i]=j+1;
					i++;
					j++;
				}
				if(j!=0&&b[i]!=b[j])//当j大于0时,b[i]b[j]不相等,j更新为前一个的next值 
				{
					j=next[j-1];
				}
			}
			num=0;
			for(i=0,j=0;i<=lena-1;)
			{
				if(a[i]==b[j])
				{
					j++;
					if(j==lenb)//找到时数量加一,j更新为前一个的next值 
					{
						num++;
						j=next[j-1];
					}	
					i++;
					
				}
				if(j==0&&a[i]!=b[j])//j等于0,a[i]与b[j]不相等时i向后查找 
					i++;
				if(j>0&&a[i]!=b[j])//j大于0,不相等j更新 
				{
					j=next[j-1];
				}
			}
			printf("%d\n",num);	
		}	
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值