UVA - 1592 Database

Peter studies the theory of relational databases. Table in the relational database consists of values that are arranged in rows and columns.

There are different normal forms that database may adhere to. Normal forms are designed to minimize the redundancy of data in the database. For example, a database table for a library might have a row for each book and columns for book name, book author, and author's email.

If the same author wrote several books, then this representation is clearly redundant. To formally define this kind of redundancy Peter has introduced his own normal form. A table is in Peter's Normal Form (PNF) if and only if there is no pair of rows and a pair of columns such that the values in the corresponding columns are the same for both rows.

How to compete in ACM ICPCPeterpeter@neerc.ifmo.ru
How to win ACM ICPCMichaelmichael@neerc.ifmo.ru
Notes from ACM ICPC championMichaelmichael@neerc.ifmo.ru

The above table is clearly not in PNF, since values for 2rd and 3rd columns repeat in 2nd and 3rd rows. However, if we introduce unique author identifier and split this table into two tables -- one containing book name and author id, and the other containing book id, author name, and author email, then both resulting tables will be in PNF.

$\textstyle \parbox{.5\textwidth}{\begin{center}\begin{tabular}{\vert l\vert l......\hlineNotes from ACM ICPC champion & 2 \\\hline\end{tabular}\end{center}}$$\textstyle \parbox{.49\textwidth}{\begin{center}\begin{tabular}{\vert l\vert ......ine2 & Michael & michael@neerc.ifmo.ru \\\hline\end{tabular}\end{center}}$

Given a table your task is to figure out whether it is in PNF or not.

Input 

Input contains several datasets. The first line of each dataset contains two integer numbers  n  and  m  (  1$ \le$n$ \le$10000, 1$ \le$m$ \le$10 ), the number of rows and columns in the table. The following  n  lines contain table rows. Each row has  m  column values separated by commas. Column values consist of ASCII characters from space (ASCII code 32) to tilde (ASCII code 126) with the exception of comma (ASCII code 44). Values are not empty and have no leading and trailing spaces. Each row has at most 80 characters (including separating commas).

Output 

For each dataset, if the table is in PNF write to the output file a single word ``  YES " (without quotes). If the table is not in PNF, then write three lines. On the first line write a single word ``  NO " (without quotes). On the second line write two integer row numbers  r1  and  r2  (  1$ \le$r1,r2$ \le$nr1$ \ne$r2 ), on the third line write two integer column numbers  c1  and  c2  (  1$ \le$c1c2$ \le$mc1$ \ne$c2 ), so that values in columns  c1  and  c2  are the same in rows  r1  and  r2 .

Sample Input 

3 3
How to compete in ACM ICPC,Peter,peter@neerc.ifmo.ru
How to win ACM ICPC,Michael,michael@neerc.ifmo.ru
Notes from ACM ICPC champion,Michael,michael@neerc.ifmo.ru
2 3
1,Peter,peter@neerc.ifmo.ru
2,Michael,michael@neerc.ifmo.ru

Sample Output 

NO
2 3
2 3
YES
 
 
本题考查字符串的处理,和map,pair的使用,不过时间有点长啊,有4s
 
#include <bits/stdc++.h>
using namespace std;

int cnt = 0;
map<string, int> id_table;
map<pair<int, int>, int> check;
int A[10240][12];

int get_id(string &x)
{
    if(id_table.count(x))
        return id_table[x];
    return (id_table[x] = cnt++);
}

int main()
{
    int n, m;
    loop:
    while(cin >> n >> m)
    {
        getchar();
        cnt = 0;
        int ch;
        for(int i = 1; i <= n; i++)
        {
            for(int j = 1; j <= m; j++)
            {
                string x;
                while((ch = getchar())!=EOF && ch!=',' && ch!='\n')
                    x += ch;
                int id = get_id(x);
                A[i][j] = id;
            }
        }

        for(int c1 = 1; c1 < m; c1++)
        {
            for(int c2 = c1 + 1; c2 <= m; c2++)
            {
                check.clear();
                for(int r = 1; r <= n; r++)
                {
                    pair<int, int> x = make_pair(A[r][c1], A[r][c2]);
                    if(check.count(x))
                    {
                        printf("NO\n");
                        printf("%d %d\n", check[x], r);
                        printf("%d %d\n", c1, c2);
                        goto loop;
                    }
                    else
                        check.insert(make_pair(x, r));

                }
            }
        }
        printf("YES\n");
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值