HDUOJ - 1316 How Many Fibs?

How Many Fibs?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4592    Accepted Submission(s): 1803


Problem Description
Recall the definition of the Fibonacci numbers:
f1 := 1
f2 := 2
fn := fn-1 + fn-2 (n >= 3)

Given two numbers a and b, calculate how many Fibonacci numbers are in the range [a, b].
 

Input
The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a = b = 0. Otherwise, a <= b <= 10^100. The numbers a and b are given with no superfluous leading zeros.
 

Output
For each test case output on a single line the number of Fibonacci numbers fi with a <= fi <= b.
 

Sample Input
  
  
10 100 1234567890 9876543210 0 0
 

Sample Output
  
  
5 4
import java.io.*;
import java.math.*;
import java.text.*;
import java.util.*;

public class Main {

	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in); 
		BigInteger []Fib = new BigInteger[1024];
		Fib[0] = Fib[1] = BigInteger.valueOf(1); 
		for(int i = 2; i < 1024; i++)
			Fib[i] = Fib[i-1].add(Fib[i-2]);
		while(cin.hasNextBigInteger()){
			BigInteger l = cin.nextBigInteger();
			BigInteger r = cin.nextBigInteger();
			int cnt = 0;
			if(l.compareTo(BigInteger.ZERO)==0 && r.compareTo(BigInteger.ZERO)==0)
				return ;
			if(l.compareTo(r) > 0){
				BigInteger t = l;
				l = r;
				r = t;
			}
			for(int i = 1; i < 1024; i++)
				if(Fib[i].compareTo(l)>=0 && Fib[i].compareTo(r)<=0)
					cnt++;
			System.out.println(cnt);
		}
			
	}

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值