UVa 12166 - Equilibrium Mobile <二叉树+DFS>

A mobile is a type of kinetic sculpture constructed to take advantage of the principle of equilibrium. It consists of a number of rods, from which weighted objects or further rods hang. The objects hanging from the rods balance each other, so that the rods remain more or less horizontal. Each rod hangs from only one string, which gives it freedom to rotate about the string.

We consider mobiles where each rod is attached to its string exactly in the middle, as in the figure underneath. You are given such a configuration, but the weights on the ends are chosen incorrectly, so that the mobile is not in equilibrium. Since that's not aesthetically pleasing, you decide to change some of the weights.

What is the minimum number of weights that you must change in order to bring the mobile to equilibrium? You may substitute any weight by any (possibly non-integer) weight. For the mobile shown in the figure, equilibrium can be reached by changing the middle weight from 7 to 3, so only 1 weight needs to changed.

Input

On the first line one positive number: the number of testcases, at most 100. After that per testcase:
  • One line with the structure of the mobile, which is a recursively defined expression of the form:
      <expr> ::= <weight> | "[" <expr> "," <expr> "]"
    with <weight> a positive integer smaller than 109 indicating a weight and [<expr>,<expr>] indicating a rod with the two expressions at the ends of the rod. The total number of rods in the chain from a weight to the top of the mobile will be at most 16.

Output

Per testcase:
  • One line with the minimum number of weights that have to be changed.

Sample Input

3
[[3,7],6]
40
[[2,3],[4,5]]

Sample Output

1
0
3
 
 
 
 
#include <bits/stdc++.h>
using namespace std;

int cur = 0;
char str[1024000];
map<long long, int> cnt;

void DFS(int dep)
{
    if(isdigit(str[cur])){
        long long a = 0;
        while(isdigit(str[cur]))
            a = a * 10 + str[cur++] - '0';
        cnt[a<<dep]++;
    }
    else{
        cur++; DFS(dep + 1);
        cur++; DFS(dep + 1);
        cur++;
    }
}

int main()
{
    ios::sync_with_stdio(false);
    int T; cin >> T; cin.get();
    while(cur = 0, cnt.clear(), T--) {
        cin >> str; DFS(0);
        int mx = INT_MIN, sum = 0;
        for(map<long long, int>::iterator it = cnt.begin(); it != cnt.end(); it++)
            sum += it->second, mx = max(mx, it->second);
        cout << sum - mx << endl;
    }
    return 0;
}


 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值