PAT (Advanced Level)1134. Vertex Cover (25) set的find函数

1134. Vertex Cover (25)

时间限制
600 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 104), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N-1) of the two ends of the edge.

After the graph, a positive integer K (<= 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:

Nv v[1] v[2] ... v[Nv]

where Nv is the number of vertices in the set, and v[i]'s are the indices of the vertices.

Output Specification:

For each query, print in a line "Yes" if the set is a vertex cover, or "No" if not.

Sample Input:
10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2
Sample Output:
No
Yes
Yes
No
No

超时代码

//1134. Vertex Cover(25)

#include <iostream>
#include<vector>
using namespace std;

struct edge {
  int left;
  int right;
};

int main() {
  int a, b;
  int i, j;
  cin >> a >> b;
  int c, d;
  vector<edge>ed(b);
  for (i = 0; i < b; i++) {//初始化
    cin >> c >> d;
    ed[i].left = c;
    ed[i].right = d;
  }
  int dx;
  cin >> dx;
  while (dx--) {
    int e;
    cin >> e;
    vector<bool>flag(b);
    for (i = 0; i < b; i++)
      flag[i] = false;
    vector<int>node(e);
    for (i = 0; i < e; i++)
      cin >> node[i];
    for (i = 0; i < b; i++)
      for (j = 0; j < e; j++)
        if (ed[i].left == node[j] || ed[i].right == node[j]) {
          flag[i] = true;
          break;
        }
    for (i = 0; i < b; i++)
      if (!flag[i]) {
        cout << "No" << endl;
        break;
      }
    if (i >= b)
      cout << "Yes" << endl;
  }
  return 0;
}

正确代码

//1134. Vertex Cover(25)

#include <iostream>
#include <set>
#include<vector>
using namespace std;

struct edge {
	int left;
	int right;
};

int main() {
	int a, b;
	int i, j;
	cin >> a >> b;
	int c, d;
	vector<edge>ed(b);
	for (i = 0; i < b; i++) {//初始化
		cin >> c >> d;
		ed[i].left = c;
		ed[i].right = d;
	}
	int dx;
	cin >> dx;
	while (dx--) {
		int e;
		cin >> e;
		bool flag = true;
		set<int>node;
		for (i = 0; i < e; i++) {
			int nodes;
			cin >> nodes;
			node.insert(nodes);
		}
			
		for (i = 0; i < b; i++) {
			if (node.find(ed[i].left) == node.end() && node.find(ed[i].right) == node.end())
			{
				flag = false;
				break;
			}
		}
		if (!flag) {
			cout << "No" << endl;
		}
		else 
			cout << "Yes" << endl;
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值