How Many Tables解题报告

D - How Many Tables
Time Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 

Sample Input

    
    
2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output

  
  
2 4 并查集的第一题实战,出现问题还蛮多的。 开始的并操作直接就是简单粗暴的a[A] = B,然后明显会超时。将其改为a[A] = SearchBoss(B)后倒是没有超时了,但是出现了Wrong Answer。 原来疏忽了,并查集的并操作应该由两边的Boss进行并才对。没做过题只有概念果然不行啊。实践出真知不会错。 贴上通过的代码。输出结果时比较繁琐。
//How Many Tables
#include <stdio.h>

int a[1001];
int BossList[1001] = {0};

void Link(int A,int B);
void Init(int Length);
int SearchBoss(int Member);
int BossExited(int Boss);
void AddBoss(int Boss);

void main()
{
	int t,ti,i;
	int n,m,ni;
	int TempA,TempB;
	int TempBoss;
	int Tables;

	scanf("%d",&t);
	for (ti = 0;ti < t;ti ++)
	{
		scanf("%d %d",&n,&m);
		Init(n);
		Tables = 0;
		for (i = 0;i < m;i ++)
		{
			scanf("%d %d",&TempA,&TempB);
			Link(TempA,TempB);
		}
		for (ni = 1;ni <= n;ni ++)
		{
			TempBoss = SearchBoss(ni);
			if (!BossExited(TempBoss))
			{
				Tables ++;
				AddBoss(TempBoss);
			}
		}
		printf("%d\n",Tables);
	}
}

void Link(int A,int B)
{
	int TempBossA,TempBossB;
	TempBossA = SearchBoss(A);
	TempBossB = SearchBoss(B);
	if (TempBossA != TempBossB)
		a[TempBossA] = TempBossB;
}

void Init(int Length)
{
	int i;
	for (i = 1;i <= Length;i ++)
	{
		a[i] = i;
		BossList[i - 1] = 0;
	}
}

int SearchBoss(int Member)
{
	while (a[Member] != Member)
	{
		Member = a[Member];
	}
	//printf("Boss %d\n",Member);
	return Member;
}

int BossExited(int Boss)
{
	int i;
	for (i = 0;BossList[i];i ++)
	{
		if (BossList[i] == Boss)
			return 1;
	}
	return 0;
}

void AddBoss(int Boss)
{
	int i;
	for (i = 0;BossList[i];i ++);
	BossList[i] = Boss;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值