kyeremal-poj1226-Substrings-模式匹配

poj1226-Substrings


Language:
Substrings
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12648 Accepted: 4460

Description

You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains a single integer n (1 <= n <= 100), the number of given strings, followed by n lines, each representing one string of minimum length 1 and maximum length 100. There is no extra white space before and after a string.

Output

There should be one line per test case containing the length of the largest string found.

Sample Input

2
3
ABCD
BCDFF
BRCD
2
rose
orchid

Sample Output

2
2 

Source


kmp算法

code:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <cstring>
#include <algorithm>

using namespace std;

#define rep(i, l, r) for (int i = l; i <= r; i++)
#define REP(i, l, r) for (int i = l; i >= r; i--)
#define MAXN 1010

int len, next[MAXN], a[MAXN][MAXN], T_T, n, minlen, l[MAXN], f[MAXN], ans;

inline void getnext(int *a, int len) {
    memset(next, 0, sizeof(next));
    next[0] = -1;
    int i = 0, j = -1;
    while(i < len-1) {
	if (!~j || a[i] == a[j]) i++, j++, next[i] = j;
	else j = next[j];
    }
}

inline bool kmp(int *s, int n, int *a, int m) {
    getnext(a, m);
    int i = 0, j = 0;
    while (i < n) {
	if (!~j || s[i] == a[j]) i++, j++;
	else j = next[j];
	if (j == m) return 1;
    }
    return 0;
}

int main() {
    cin >> T_T;
    while (T_T--) {
	ans = 0;
	cin >> n;
	minlen = 12345678;
	char ch[MAXN];
	int kk;
	rep(i, 1, n) {
	    scanf("%s", ch);
	    if (int(strlen(ch)) < minlen) {
		minlen = int(strlen(ch));
		kk = 2*i - 1;
	    }
	    minlen = min(minlen, int(strlen(ch)));
	    rep(j, 0, strlen(ch)-1) a[2*i-1][j] = int(ch[j]);
	    rep(j, 0, strlen(ch)-1) a[2*i][strlen(ch)-1-j] = int(ch[j]);
	    l[2*i-1] = l[2*i] = strlen(ch);
	}
	rep(L, 0, minlen-1) {
	    rep(R, L, minlen-1) {
		memset(f, 0, sizeof(f));
		rep(i, 0, R-L) f[i] = a[kk][i+L];
		bool flag = 0;
		rep(i, 1, n)
		    if (!kmp(a[2*i-1], l[2*i-1], f, R-L+1) && !kmp(a[2*i], l[2*i], f, R-L+1)) {
			flag = 1;
			break;
		    }
		if (!flag) ans = max(ans, R-L+1);
	    }
	}
	cout << ans << endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值