PAT A1037 Magic Coupon (25分)

PAT A1037 Magic Coupon 25分

原题

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!
For example, given a set of coupons{ 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.
Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.
Input Specification:
Each input file contains one test case. For each case, the first line contains the number of coupons N​C​​ , followed by a line with N​C​​ coupon integers. Then the next line contains the number of products N​P​​ , followed by a line with N​P​​ product values. Here 1≤N​C​​ ,N​P​​ ≤10​5​​ , and it is guaranteed that all the numbers will not exceed 2​30​​ .
Output Specification:
For each test case, simply print in a line the maximum amount of money you can get back.
Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

题目分析

其实就是不断在两个部分里挑两个数相乘并将结果相加使和最大
因此可以将题目分成两部分,分别是两边都是正的数和两边都是负的数
对于两边都是正的数的部分,不断把最大的两个值相乘求和即可
对于两边都是负的数的部分,不断把最小的两个值相乘求和即可
直到有一边没有数字可以运算了为止

第一次使用了set来存储数据,因为set可以自动排序,结果测试点4无法通过,后来去百度了一下,原来是因为set的去重操作,所以就改成了数组然后用sort进行排序

由此可见,还是尽可能少用set,要不然考试的时候可能想不到是因为set的去重导致不能通过所有的测试点

代码

#include <iostream>
using namespace std;
#define maxs 100010
#include <algorithm>

//cou_positive,cou_negative,pro_positive,pro_negative
int cp[maxs], cn[maxs], pp[maxs], pn[maxs];
//cp_num,cn_num,pp_num,pn_num
int cpn = 0, cnn = 0, ppn = 0, pnn = 0;
//coupon_num,product_num
int cou, pro;

bool cmp(int a, int b)
{
	return a > b;
}

int main()
{
	int d;
	cin >> cou;
	for (int i = 0; i < cou; i++)
	{
		cin >> d;
		if (d >= 0)
			cp[cpn++] = d;
		else
			cn[cnn++] = d;
	}
	cin >> pro;
	for (int i = 0; i < pro; i++)
	{
		cin >> d;
		if (d >= 0)
			pp[ppn++] = d;
		else
			pn[pnn++] = d;
	}
	//sort
	sort(cp, cp + cpn, cmp);//large to small
	sort(cn, cn + cnn);//small to large
	sort(pp, pp + ppn, cmp);//large to small
	sort(pn, pn + pnn);//small to large
	
	int sum = 0;
	for (int i = 0, j = 0; i < cpn&&j < ppn; i++, j++)
		sum += cp[i] * pp[j];
	for (int i = 0, j = 0; i < cnn&&j < pnn; i++, j++)
		sum += cn[i] * pn[j];
	cout << sum << endl;
	return 0;
}

运行结果

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值